Bug 1180990 - rabbitmq-server is installing files under /etc/tmpfiles.d/
Summary: rabbitmq-server is installing files under /etc/tmpfiles.d/
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rabbitmq-server
Version: 7.0 (Kilo)
Hardware: All
OS: Linux
low
unspecified
Target Milestone: ---
: 8.0 (Liberty)
Assignee: Peter Lemenkov
QA Contact: Ofer Blaut
URL:
Whiteboard:
Keywords: FutureFeature, Triaged, ZStream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-12 05:43 UTC by Morgan Weetman
Modified: 2016-04-26 19:11 UTC (History)
16 users (show)

(edit)
Clone Of: 1180984
(edit)
Last Closed: 2015-11-05 15:56:03 UTC


Attachments (Terms of Use)

Description Morgan Weetman 2015-01-12 05:43:51 UTC
Description of problem:
Package is installing files under /etc/tmpfiles.d/, according to 'man 5 tmpfiles.d':-

"Packages should install their configuration files in /usr/lib/tmpfiles.d. Files in /etc/tmpfiles.d are reserved for the local administrator, who may use this logic to override the configuration files installed by vendor packages"


Version-Release number of selected component (if applicable):
rabbitmq-server-0:3.1.5-6.3.el7ost.noarch
rabbitmq-server-0:3.3.5-2.el7ost.noarch

How reproducible:
repoquery --whatprovides "/etc/tmpfiles.d/*" | grep ^rabbitmq

Actual results:
rabbitmq-server-0:3.1.5-6.3.el7ost.noarch
rabbitmq-server-0:3.3.5-2.el7ost.noarch


Expected results:
Should return nothing

Additional info:

Comment 2 Richard W.M. Jones 2015-01-19 13:16:37 UTC
FWIW I went ahead and fixed this in Fedora Rawhide.  The same
patch could probably be applied to RHEL 7.

http://pkgs.fedoraproject.org/cgit/rabbitmq-server.git/commit/rabbitmq-server.spec?id=b78a62527828b56b3f11c92aa4cd67ff6586727a

Comment 5 Peter Lemenkov 2015-11-05 15:56:03 UTC
Ok, since it's a low priority minor enhancement I've built it for RHOS8. There is no strong reasoning for implementing any additional minor functionality for the already released platforms. So I'm going to close it as NEXTRELEASE.

Feel free to reopen/clone if you need a build for a specific version already released.


Note You need to log in before you can comment on or make changes to this bug.