Bug 118100 - gdmgreeter keeps crashing endlessly
gdmgreeter keeps crashing endlessly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-11 17:13 EST by mark
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-17 07:05:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug log for gdm (316.80 KB, text/plain)
2004-03-18 07:13 EST, Adrian Rees
no flags Details
strace of gdm (64.85 KB, text/plain)
2004-03-19 18:55 EST, mark
no flags Details

  None (edit)
Description mark 2004-03-11 17:13:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6) Gecko/20040113

Description of problem:
for some reason X will not load correctly. It hangs endlessly with the
default background and an hourglass. i'm able to use ctrl-alt-1 to run
"top". when i do this, i notice that gdmgreeter is using 50% of the
CPU and keeps restarting (it keeps changing its PID). any ideas how to
fix this? my packages were update via rawhide as of yesterday. this
problem has occurred since i first updated from rawhide after
installing FC Core 2 Test 1. any help would be greatly appreciated...
in the meantime, i guess i'll have to keep ssh'ing into the box and
running X apps from it. thanks again...

Version-Release number of selected component (if applicable):
gdm-2.5.90-2.1

How reproducible:
Always

Steps to Reproduce:
1. boot the machine
2.
3.
    

Additional info:
Comment 1 mark 2004-03-11 18:47:29 EST
if i ctrl-alt-1 while the above description is occuring, then i see
the following error message:

gdm(pam_unix) [1190] : bad username [] 
Comment 2 Adrian Rees 2004-03-18 07:13:35 EST
Created attachment 98649 [details]
Debug log for gdm

Extract of log showing debug messages from gdm.
Comment 3 Adrian Rees 2004-03-18 07:29:22 EST
I'm seeing the same problem - I upgraded from Redhat 9 to Fedora Core
1 with no problems. Then I applied the latest updates using yum, and
now my desktop is screwed. Gnome sits with a blue background and
spinning hourglass as described. KDE just keeps restarting the X
server so I can't even use ctl-alt-F1.

I don't see the high CPU use, but gdmgreeter does keep restarting. I
enabled debugging on gdm, and have attached the relevant bits from my
log file. Howvever, all this tells me is that gdm_slave_child_handler
is dying unexpectedly.

I tried to strace another instance of gdmgreeter while the X server
was up - it traced for a while but then bombed with the following error:
strace: ptrace(PTRACE_TRACEME, ...): Operation not permitted

Any hints as to where to go next would be appreciated!

Using gdm-2.4.4.5-1.2 and a source built kernel from source rpm
kernel-source-2.4.20-8
Comment 4 mark 2004-03-19 18:55:41 EST
Created attachment 98700 [details]
strace of gdm
Comment 5 mark 2004-03-19 18:56:31 EST
the problem persists with 

kernel 2.6.4-1.275
gdm-2.5.90.2-3
gtk2-2.4.0-1
xorg-x11-0.0.6.6-0.0.2004_03_11.6

i've enclosed a copy of my strace as an attachment
Comment 6 mark 2004-03-31 11:43:45 EST
after installing FC2 test2, i can no longer produce this bug... it
appears this bug has been squashed.
Comment 7 Warren Togami 2004-04-17 07:05:51 EDT
There are at least a dozen different causes for this that may have
been fixed since then.  Please REOPEN only if you find isolate a very
specific cause.

Note You need to log in before you can comment on or make changes to this bug.