Bug 118102 - (NET ACENIC)oops during bootup in ethtool
Summary: (NET ACENIC)oops during bootup in ethtool
Status: CLOSED DUPLICATE of bug 119491
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-03-11 22:25 UTC by Fred Isaman
Modified: 2013-07-03 02:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot messages and scanpci dump (28.57 KB, text/plain)
2004-03-11 22:26 UTC, Fred Isaman
no flags Details
Boot log with oops (selinux=0) (8.78 KB, text/plain)
2004-03-18 19:15 UTC, Fred Isaman
no flags Details

Description Fred Isaman 2004-03-11 22:25:11 UTC
Description of problem:
  Did upgrade from Fedora Core release 1 (Yarrow) to
Fedora Core 2 test 1.  First try got to "About to Upgrade" screen,
then eventually reported there was not enough disk space in /usr.
I deleted /usr/doc, and retried.  Worked until tried to reboot after
install, when it gave an oops during running of ethtool.  This oops
happens every time with the Fedora kernel (2.6.1-1.65).  It does not
happen if I boot with vanilla 2.6.1 or with a CITI patched
2.6.3-citiall-02.

Version-Release number of selected component (if applicable):
  Fedora Core 2 test 1

Additional info:
  I've attached the boot messages from the (nonworking) Fedora kernel
and another (working) kernel, as well as output from scanpci.

Comment 1 Fred Isaman 2004-03-11 22:26:16 UTC
Created attachment 98469 [details]
boot messages and scanpci dump

Comment 2 Bill Nottingham 2004-03-12 01:31:05 UTC
Looks like a driver bug.

Comment 3 Sahil Verma 2004-03-17 23:33:57 UTC
I guess the difference between FC2 test1 kernel and the vanilla / CITI
kernels you're using is that the latter don't have SELinux compiled
in, right?

Does the oops happen if you don't bringup the eth interface in
interactive startup but later using ifconfig? Do you get the same oops
trace?

Comment 4 Sahil Verma 2004-03-18 02:47:21 UTC
Oh, silly me. It is totally obvious from your boot logs that SELinux
is not enabled in vanilla / CITI kernels. If you boot FC2 test1 with
selinux=0 the oops should go away.

That doesn't explain the panic though.

Comment 5 Fred Isaman 2004-03-18 14:16:24 UTC
                                                                     
           Yes, oops still happens if use interactive startup to avoid
bringing
up the eth interface and then later using ifconfig.

Here is relevant snippet from bootup

Start service network (Y)es/(N)o/(C)ontinue? [Y]
Setting network parameters:  [  OK  ]
Bringing up loopback interface:  [  OK  ]
Start service eth1 (Y)es/(N)o/(C)ontinue? [Y] n
Start service syslog (Y)es/(N)o/(C)ontinue? [Y] c

Then as root `ifconfig eth1 up` causes basically same oops.


Comment 6 Sahil Verma 2004-03-18 18:54:38 UTC
Ok, at the boot menu press 'e' to edit the args and append 'selinux=0'
to the 'kernel' line. Does that make the oops go away?

Comment 7 Fred Isaman 2004-03-18 19:15:12 UTC
Created attachment 98660 [details]
Boot log with oops (selinux=0)

Adding selinux=0 still has oops (with slightly different stack trace)

Comment 8 Alan Cox 2004-05-03 17:55:59 UTC

*** This bug has been marked as a duplicate of 119491 ***

Comment 9 Red Hat Bugzilla 2006-02-21 19:01:56 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.