Bug 118110 - up2date wants to replace newer package with older one
up2date wants to replace newer package with older one
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks: up2date-fc2 120092
  Show dependency treegraph
 
Reported: 2004-03-11 19:27 EST by Ronald Cole
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:29:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Cole 2004-03-11 19:27:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
I built and installed xmms-1.2.10-1.  Now, when I run up2date, it
wants to install xmms-1.2.7-22.1.p over it because it thinks it's
newer (which is clearly incorrect).

Version-Release number of selected component (if applicable):
up2date-4.2.5-1

How reproducible:
Always

Steps to Reproduce:
1.  rpm -Uvh xmms*-1.2.10-1.i386.rpm
2.  up2date -l
3.
    

Actual Results:  # rpm -q xmms
xmms-1.2.10-1
# up2date -l
 
Fetching package list for channel: rhel-i386-es-3...
########################################
 
Fetching Obsoletes list for channel: rhel-i386-es-3...
 
Fetching rpm headers...
########################################
 
Name                               Version        Rel
-----------------------------------------------------
xmms                               1.2.7          22.1.p     i386    
                                                                     
      
 
The following Packages are obsoleted by newer packages:
 
Name-Version-Release        obsoleted by      Name-Version-Release
-------------------------------------------------------------------------------
xmms-esd-1.2.10-1                       xmms-1.2.7-22.1.p
xmms-gl-1.2.10-1                        xmms-1.2.7-22.1.p


Expected Results:  up2date should recognize that package version
1.2.10-1 is newer than package version 1.2.7-22.1.p and not try to
replace it!

Additional info:
Comment 1 Adrian Likins 2004-03-22 16:30:44 EST
what is the epoch of the 1.2.10-1 package?

 rpm -q --queryformat "%{EPOCH}\n" xmms
Comment 2 Ronald Cole 2004-03-22 20:02:11 EST
1
Comment 3 Adrian Likins 2004-03-23 13:53:49 EST
Looks like it must be the obsoletes. Upstream xmms obsoletes
all versions of xmms-esd and xmms-gl, so it gets pulled in
that way. 

Not sure off hand what the right thing to do in that
case is, since leaving dangling obsoletes means
broken systems in the standard case. 

Probabaly just need a check to make sure packages
pulled in by obsoletes are newer than whats installed.
I belive that shouldn't break any legitimate updates,
and should work around cases like this.
Comment 4 RHEL Product and Program Management 2007-10-19 15:29:04 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.