Bug 118112 - patch to build subversion perl modules
patch to build subversion perl modules
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 20:30 EST by Steven Pritchard
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.0.0-3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-12 05:13:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec changes (2.46 KB, patch)
2004-03-11 20:31 EST, Steven Pritchard
no flags Details | Diff
spec changes, take 2 (3.38 KB, patch)
2004-03-12 03:20 EST, Steven Pritchard
no flags Details | Diff
spec file -3 (10.42 KB, text/plain)
2004-03-12 03:24 EST, Joe Orton
no flags Details

  None (edit)
Description Steven Pritchard 2004-03-11 20:30:23 EST
The attached patch adds a -perl subpackage to the subversion package.

The SVN modules are required by various things, and they aren't
available separate from the subversion source, so adding this patch to
the spec would be a Good Thing.

This patch is against subversion-1.0.0-2.1 in rawhide.
Comment 1 Steven Pritchard 2004-03-11 20:31:45 EST
Created attachment 98477 [details]
spec changes
Comment 2 Steven Pritchard 2004-03-11 22:07:36 EST
Comment on attachment 98477 [details]
spec changes

That first hunk is bogus.  Plus libsvn_swig_perl-1.so.0 ends up in the main
package instead of in the -perl subpackage.  I'll fix both and resubmit.
Comment 3 Steven Pritchard 2004-03-12 03:20:52 EST
Created attachment 98480 [details]
spec changes, take 2

Unfortunately, this patch uglies up the spec file just a bit.  I couldn't think
of a good way to say that we want libsvn_swig_perl and nothing else in /usr/lib
without spelling it out.

The good news is that it seems to install properly.  The main package is in no
way dependent on the -perl subpackage.
Comment 4 Joe Orton 2004-03-12 03:23:29 EST
%exclude is your friend :)

Thanks a lot Steve, this looks great; I added this in with changes to:

- use %exclude to put libsvn_swig_perl in the -perl subpackage
- make the Perl module .so's chmod 755 so they get stripped
- remove the unnecessary libdir/libsvn_swig_*.{a,la,so}

I'll attach the new spec file
Comment 5 Joe Orton 2004-03-12 03:24:01 EST
Created attachment 98481 [details]
spec file -3
Comment 6 Steven Pritchard 2004-03-12 03:27:06 EST
I either forgot about, or never knew about, %exclude.  Either way,
I'll keep that in mind for next time.  :-)

Thanks for taking a look at this so quickly.
Comment 7 Joe Orton 2004-03-12 03:28:08 EST
Oh, what about those empty .bs files; are they needed?
Comment 8 Steven Pritchard 2004-03-12 03:41:26 EST
I get the impression (doing some quick reading on
ExtUtils::Mkbootstrap) that those files shouldn't be created
zero-length, so there's probably a bug there somewhere.  I'd guess
that means it is OK to clean them out.

Perhaps cturner would have a better answer?
Comment 9 Joe Orton 2004-03-12 05:13:53 EST
Looks like zero-length .bs files can safely be removed from some
googling; I'll do that for the next build.  Meanwhile, this is built
for Raw Hide - thanks again.

Note You need to log in before you can comment on or make changes to this bug.