Bug 118123 - kdm accesses /dev/mem
kdm accesses /dev/mem
Status: CLOSED DUPLICATE of bug 118051
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-12 00:56 EST by Russell Coker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2004-03-12 00:56:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
audit(1079007629.554:0): avc:  denied  { read } for  pid=2098 exe=/usr/bin/kdm name=mem dev=hda2 ino=2683359 scontext=system_u:system_r:xdm_t tcontext=system_u:object_r:memory_device_t tclass=chr_file

Above is an AVC message reported by a Fedora SE Linux user.  It shows that kdm is accessing /dev/mem.  I believe that this is the old "use kernel memory as source of random numbers" thing, it should be replaced by use of /dev/random.  There is no reason why kdm (or any xdm type program) should directly access /dev/mem.

Allowing kdm to access /dev/mem allows it to entirely break the system's security if it is compromised.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Just run kdm.  It's easy to observe on SE Linux, but when not running SE Linux strace should show it.

Additional info:
Comment 1 Aleksey Nogin 2004-03-12 01:21:15 EST

*** This bug has been marked as a duplicate of 118051 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.