Bug 1181233 - Problem parsing stomp frames where trailing \0 was cut off
Summary: Problem parsing stomp frames where trailing \0 was cut off
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Piotr Kliczewski
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks: 1195116
TreeView+ depends on / blocked
 
Reported: 2015-01-12 16:12 UTC by Saggi Mizrahi
Modified: 2016-03-09 19:29 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1195116 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:29:05 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC
oVirt gerrit 36806 ovirt-3.5 MERGED stomp: Make sure the \0 is read before slicing the buffer Never
oVirt gerrit 37018 master MERGED stomp: Make sure the \0 is read before slicing the buffer Never

Description Saggi Mizrahi 2015-01-12 16:12:38 UTC
Description of problem:
If VDSM gets a stomp frame with the content-length header and the frame cuts off just missing the terminating '\0' the frame parser will have issues parsing subsequent messages.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Pavel Novotny 2015-03-02 14:37:01 UTC
Barak, can you provide steps how to verify this?

Comment 6 Piotr Kliczewski 2015-03-02 15:20:57 UTC
This bug is time dependent and it is very hard to have a reproducer. When vdsm code handles messages there maybe an issue when network frame contains most of the message except of '\0'. When this rare situation occurs parser was not able to process the message.

We run a unit test with several thousand operations to find this issue.

Comment 7 Pavel Novotny 2015-03-13 17:40:02 UTC
Piotr, have you had any luck with reproducing the problem running your unit tests?
Or is there another way how QA can for example fake or tamper STOMP frames in order to verify the bug?

Comment 8 Piotr Kliczewski 2015-03-16 07:42:25 UTC
I do not see this issue in my tests anymore. You would need to create a client which generates heavy load on stomp server ~5k messages per second.

Comment 10 Pavel Novotny 2015-10-02 08:57:09 UTC
Piotr, can you please help us again to verify this bug, the same way as in 3.5.1 (bug 1195116 comment 2) ?
Can you run your unit tests against 3.6 VDSM if you manage to reproduce or not?

Comment 11 Piotr Kliczewski 2015-10-02 10:44:35 UTC
I run the tests for 3.6 and I do not see this issue.

Comment 12 Pavel Novotny 2015-10-02 11:02:30 UTC
(In reply to Piotr Kliczewski from comment #11)
> I run the tests for 3.6 and I do not see this issue.

Thank you, Piotr.

Based on this I am moving the bug to VERIFIED (vdsm-4.17.8-1.el7ev, build 3.6.0-15).

Comment 14 errata-xmlrpc 2016-03-09 19:29:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.