Bug 118125 - sudo runs commands with wrong stdout
sudo runs commands with wrong stdout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-12 01:58 EST by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 11:25:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-03-12 01:58:41 EST
Sudo recently started redirecting the stdout of the commands somewhere
else.

It works correctly on Fedora Core 1:

% /usr/bin/sudo echo foo > /dev/null
% rpm -q sudo
sudo-1.6.7p5-2

But fails in Raw Hide:

% /usr/bin/sudo echo foo > /dev/null
foo
% sudo-1.6.7p5-18

P.S. really annoying - for example, things like

sudo grep something /var/log/something | less

no longer work as expected :-(
Comment 1 Thomas Woerner 2004-03-15 04:58:29 EST
I can not reproduce this bug:

$ /usr/bin/sudo echo foo > /dev/null
$ rpm -q sudo
sudo-1.6.7p5-18
$ 

$ sudo grep kernel /var/log/messages | less
Works, too.

Do you have any special settings for root?
Comment 2 Aleksey Nogin 2004-03-15 14:46:38 EST
> Do you have any special settings for root?

I do not believe so.
Comment 3 Nils Philippsen 2004-03-16 05:35:25 EST
Perhaps this is some shell issue. From the prompt, it looks like you,
Aleksey use csh/tcsh while Thomas uses bash. Is it like this?
Comment 4 Aleksey Nogin 2004-03-16 06:09:56 EST
Yes, I use tcsh, but the root's shell is still bash.
Comment 5 Thomas Woerner 2004-03-16 11:01:56 EST
This is an error in the SElinux patch for sudo.
Comment 7 Thomas Woerner 2004-03-17 11:24:59 EST
Fixed in rawhide in rpm sudo-1.6.7p5-20 or newer.
Comment 8 Aleksey Nogin 2004-03-17 22:52:46 EST
Confirming fixed.

Note You need to log in before you can comment on or make changes to this bug.