Bug 118134 - Improper handle of PCMCIA network cards in pcmcia init script
Improper handle of PCMCIA network cards in pcmcia init script
Status: CLOSED DUPLICATE of bug 44177
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2004-03-12 06:49 EST by Cristiano Duarte
Modified: 2014-03-16 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:01:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Cristiano Duarte 2004-03-12 06:49:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031010

Description of problem:
My PCMCIA network card is not waiting for configuration (dhclient), so
all network services that depends on it fail.
I figure out that the startup sequence is causing the problem. When
the startup "pcmcia" service is moved to place 09 instead of 24, all
network services work.
This new behaviour is the same as PCI ethernet cards, since dhclient
waits for DHCP configuration.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Just turn on a notebook with a PCMCIA network card and a network
service like ntpd configured at boot.

Actual Results:  The network script runs. Since there is no PCMCIA
card configured, it does not configure eth0.
The pcmcia script runs. The network configuration doesn't wait for the
DHCP message and continue the init sequence.
The ntpd script fails since there is no IP address configured yet.

Expected Results:  no ntpd fail or any other network service fail

Additional info:

Maybe it's not necessary to move the pcmcia script to place 09, if the
pcmcia script waits for DHCP configuration.
Comment 1 Bill Nottingham 2004-03-12 14:14:52 EST

*** This bug has been marked as a duplicate of 44177 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.