Bug 1181397 - [abrt] dnf: output.py:683:_display_packages_verbose:KeyError: u'ppc64-utils'
Summary: [abrt] dnf: output.py:683:_display_packages_verbose:KeyError: u'ppc64-utils'
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 21
Hardware: x86_64 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:720f7513de6558d3267f7008c4a...
Keywords:
: 1185543 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-13 05:05 UTC by Parag Nemade
Modified: 2015-02-20 08:32 UTC (History)
7 users (show)

Fixed In Version: hawkey-0.5.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-20 08:32:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.00 KB, text/plain)
2015-01-13 05:05 UTC, Parag Nemade
no flags Details
File: environ (2.18 KB, text/plain)
2015-01-13 05:05 UTC, Parag Nemade
no flags Details

Description Parag Nemade 2015-01-13 05:05:53 UTC
Description of problem:
enable debugging in /etc/dnf/dnf.conf
debuglevel=10

then execute command
sudo dnf groupinfo core | grep yum

this will trigger this abrt report.

Version-Release number of selected component:
dnf-0.6.3-2.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python -OO /bin/dnf groupinfo core
executable:     /bin/dnf
kernel:         3.17.8-300.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
#1 _display_packages_verbose in /usr/lib/python2.7/site-packages/dnf/cli/output.py:683
#2 display_pkgs_in_groups in /usr/lib/python2.7/site-packages/dnf/cli/output.py:723
#3 _info in /usr/lib/python2.7/site-packages/dnf/cli/commands/group.py:197
#4 run in /usr/lib/python2.7/site-packages/dnf/cli/commands/group.py:442
#5 run in /usr/lib/python2.7/site-packages/dnf/cli/cli.py:1059
#6 _main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:134
#7 main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:84
#8 user_main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:182
#9 <module> in /bin/dnf:36

Comment 1 Parag Nemade 2015-01-13 05:05:57 UTC
Created attachment 979465 [details]
File: backtrace

Comment 2 Parag Nemade 2015-01-13 05:05:59 UTC
Created attachment 979466 [details]
File: environ

Comment 3 Honza Silhan 2015-01-15 19:21:32 UTC
Thanks for the report. Fixed in the upstream.

Comment 4 Parag Nemade 2015-01-25 05:19:54 UTC
*** Bug 1185543 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2015-02-16 00:03:31 UTC
dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21

Comment 6 Fedora Update System 2015-02-17 08:04:25 UTC
Package hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.3-2.fc21 dnf-plugins-core-0.1.5-1.fc21 dnf-0.6.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2139/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-02-20 08:32:47 UTC
hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.