Bug 118151 - unable to bring up lcs eth interface
unable to bring up lcs eth interface
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-12 10:52 EST by Brock Organ
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 18:11:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Brock Organ 2004-03-12 11:16:51 EST
* RHEL3, RHEL3-U1
* reported by customer, verified internally
* configuring the installer to use a lcs ethernet interface
* error observed in following scenarios:  
  - RHEL3 in LPAR (s390x)
  - RHEL3 in z/VM 4.4 guest account (s390, s390x)
  - RHEL3-U1 in z/VM 4.4 guest account (s390, s390x)
* this was tested (worked) in RHEL3 originally (with previous z/VM
version and different LIC level)

Ipl the boot kernel:

> Starting the S/390 initrd to configure networking. Version is 1.01 
> Starting lcs module  $Revision: 1.1.2.1 $ $Date: 2002/03/29 00:14:37 
> $  
> with chandev support,with multicast support, with ethernet support, 
> with token ring support. 
> lcs_sleepon network card taking time responding irq=0014 devno=0c00, 
> please be patient, ctrl-c will exit if shell prompt is available. 
> lcs_sleepon network card taking time responding irq=0014 devno=0c00, 
> please be patient, ctrl-c will exit if shell prompt is available.  
            
> lcs_sleepon network card taking time responding irq=0014 devno=0c00, 
> please be patient, ctrl-c will exit if shell prompt is available. 
> A partially successful startup read_devno=0c00 write_devno= c01 was 
> detected rc=-4 
> please check your configuration parameters,cables & connection to 
> the network. 
> No lcs capable cards found 
> Terminating lcs module. 
> /tmp/lcs.o: init_module: No such device 
> Hint: insmod errors can be caused by incorrect module parameters,
including inva
> lid IO or IRQ parameters. 
>       You may find more information in syslog or the output from dmesg 
> SIOCSIFADDR: No such device 
> lcs0: unknown interface: No such device 
> SIOCSIFMTU: No such device 
> SIOCSIFNETMASK: No such device 
> SIOCSIFBRDADDR: No such device 
> lcs0: unknown interface: No such device 
> <...>
> Starting telnetd and sshd to allow login over the network. 
>  
> Connect now to 192.168.5.109 to start the installation. 

we can see that the linux kernel finds the devices, but the lcs
modules isn't able to see them:

> sh-2.05b# cat /proc/chandev
> <...>
> channels detected 
>               chan    cu    cu   dev    dev                          
> in chandev 
>   irq  devno  type   type  model type  model pim      chpids         
> use  reg. 
> 
>===============================================================================

> <...>
> 0x0014 0x0c00 0x04  0x3088 0x60  0x0000 0x00 0x80 0x0a00000000000000  
> no   no   
>  
> 0x0015 0x0c01 0x04  0x3088 0x60  0x0000 0x00 0x80 0x0a00000000000000  
> no   no   
>  
> sh-2.05b# 

and querying the VM environment (in this example) shows the devices to
be properly present:

> Connect now to 192.168.5.109 to start the installation. 
> 00:  
> 00: CP Q OSA
> <...>
> 00: OSA  0C00 ON OSA   0C00 SUBCHANNEL = 0014
> 00: OSA  0C01 ON OSA   0C01 SUBCHANNEL = 0015

Comment 3 Pete Zaitcev 2004-03-13 00:00:50 EST
Is this possible to reproduce on an installed system?
Comment 4 Pete Zaitcev 2004-03-16 20:16:47 EST
So far anything I do was not successful.

Brock provided me access to tagore, and it has an installed system.

The lcs module enters lcs_probe -> lcs_detect -> lcs_startlan,
sends startlan (01), does not receive any reply.

I tried the ancient driver from RHL 7.2 product, it does not work.
Brock told me that "a pre-GA" Taroon ran on tagore, but I fail
to see how this can be possible.

I suspect strongly that configuration somehow disables the card.
Comment 5 Brock Organ 2004-04-19 18:11:07 EDT
customer has verified lcs works with recent test tree ...

Note You need to log in before you can comment on or make changes to this bug.