Bug 118153 - 'env: /etc/init.d/yum: Permission denied' while upgrading
'env: /etc/init.d/yum: Permission denied' while upgrading
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks: 122683
  Show dependency treegraph
 
Reported: 2004-03-12 11:18 EST by Tim Waugh
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 21:38:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-03-12 11:18:38 EST
Description of problem:
While upgrading yum to yum-2.0.5.20040310-1 (from previous build), I
got this error:

[root@tornado RPMS]# rpm -Fvh stunnel* tk* yum* yelp* patchutils*
error: failed to stat /var/lib/rpc_pipes: Permission denied
Preparing...               
########################################### [100%]
   1:tk                    
########################################### [ 20%]
   2:stunnel               
########################################### [ 40%]
   3:yum                   
########################################### [ 60%]
env: /etc/init.d/yum: Permission denied
   4:yelp                  
########################################### [ 80%]
   5:patchutils            
########################################### [100%]

dmesg shows:
avc:  denied  { transition } for  pid=3481 exe=/bin/env
path=/etc/rc.d/init.d/yum dev=hdb1 ino=344128
scontext=root:sysadm_r:rpm_script_t tcontext=root:system_r:initrc_t
tclass=process

and audit2allow says:
allow rpm_script_t initrc_t:process { transition };

Version-Release number of selected component (if applicable):
yum-2.0.5.20040310-1
policy-1.8-11

(I had added 'role sysadm_r types ldconfig_t;' to
/etc/security/selinux/src/policy/domains/program/ldconfig.te and 
reloaded policy in order to get package upgrading to work this well.)

How reproducible:
Not sure.
Comment 1 Seth Vidal 2004-05-07 00:19:59 EDT
I'm not sure how this is a yum bug.  It sounds more like a policy issue.
Comment 2 Jeff Johnson 2004-06-09 21:38:17 EDT
This probably long since fixed. certainly not seen by me.

Note You need to log in before you can comment on or make changes to this bug.