Bug 1181637 - RFE: Please add --no-clean, --no-cleanup-after options to mockbuild
Summary: RFE: Please add --no-clean, --no-cleanup-after options to mockbuild
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpkg
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavol Babinčák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 716370 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-13 14:11 UTC by Jaroslav Škarvada
Modified: 2015-05-10 23:40 UTC (History)
6 users (show)

Fixed In Version: rpkg-1.33-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 19:27:26 UTC


Attachments (Terms of Use)
Proposed patch (1.74 KB, patch)
2015-01-13 14:11 UTC, Jaroslav Škarvada
no flags Details | Diff

Description Jaroslav Škarvada 2015-01-13 14:11:16 UTC
Created attachment 979634 [details]
Proposed patch

Description of problem:
These two options are useful, because they can speed up things during iterative development. Also alias for these two options would be handy.

Version-Release number of selected component (if applicable):
pyrpkg-1.28-1.fc21.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try to use mockbuild without cleaning the chroot

Actual results:
It is currently possible to do it by:
MOCKARGS="--no-clean --no-cleanup-after" fedpkg mockbuild

Expected results:
More simple approach, e.g.:
fedpkg mockbuild -N

Additional info:
Attached patch adds --no-clean, --no-cleanup-after mock options and -N or --no-clean-all which is alias for both options.

Upstream report:
https://fedorahosted.org/rpkg/ticket/28

Comment 1 Karel Volný 2015-01-23 10:43:05 UTC
*** Bug 716370 has been marked as a duplicate of this bug. ***

Comment 2 Orion Poplawski 2015-03-19 01:49:17 UTC
This is really helpful for failed builds where you need to look into the chroot to see what happened.  I might even argue that for a failed build not cleaning up should be the default.

Comment 3 Fedora Update System 2015-04-15 09:06:22 UTC
rpkg-1.33-1.fc20,fedpkg-1.20-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rpkg-1.33-1.fc20,fedpkg-1.20-1.fc20

Comment 4 Fedora Update System 2015-04-15 09:19:13 UTC
rpkg-1.33-1.fc21,fedpkg-1.20-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/rpkg-1.33-1.fc21,fedpkg-1.20-1.fc21

Comment 5 Fedora Update System 2015-04-15 15:51:37 UTC
rpkg-1.33-1.fc22,fedpkg-1.20-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/rpkg-1.33-1.fc22,fedpkg-1.20-1.fc22

Comment 6 Fedora Update System 2015-04-15 15:54:54 UTC
rpkg-1.33-1.el7,fedpkg-1.20-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/rpkg-1.33-1.el7,fedpkg-1.20-1.el7

Comment 7 Fedora Update System 2015-04-16 08:58:37 UTC
rpkg-1.34-1.el6,fedpkg-1.20-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rpkg-1.34-1.el6,fedpkg-1.20-1.el6

Comment 8 Fedora Update System 2015-04-17 18:15:08 UTC
Package rpkg-1.33-1.el7, fedpkg-1.20-1.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing rpkg-1.33-1.el7 fedpkg-1.20-1.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-5830/rpkg-1.33-1.el7,fedpkg-1.20-1.el7
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-04-21 19:27:26 UTC
rpkg-1.33-1.fc22, fedpkg-1.20-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-04-27 08:41:23 UTC
rpkg-1.33-1.fc21, fedpkg-1.20-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-05-08 16:39:32 UTC
rpkg-1.34-1.el6, fedpkg-1.20-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-05-08 16:41:57 UTC
rpkg-1.33-1.el7, fedpkg-1.20-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-05-10 23:40:36 UTC
rpkg-1.33-1.fc20, fedpkg-1.20-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.