Bug 1181671 - Missing CONTROLSCALE variable in deploy-overcloudrc
Summary: Missing CONTROLSCALE variable in deploy-overcloudrc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: Director
Assignee: Jan Provaznik
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-13 14:58 UTC by Jan Provaznik
Modified: 2015-08-05 13:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Jan Provaznik 2015-01-13 14:58:09 UTC
Description of problem:
After running instack-install-undercloud and when ~/deploy-overcloudrc file is created there is no CONTROLSCALE variable defined in it. If we support scaling out control nodes we should add this variable (default to CONTROLSCALE=1) too. Or otherwise put into instack documentation that a user should set/add CONTROLSCALE=X for scaling out ctrl nodes.

Note that there is an important bug related to scaling controller nodes:
https://bugzilla.redhat.com/show_bug.cgi?id=1175685

Version-Release number of selected component (if applicable):
instack-0.0.6-1.el7ost.noarch
instack-undercloud-1.0.34-1.el7ost.noarch

Comment 3 chris alfonso 2015-05-26 17:46:38 UTC
Jan, Please coordinate with the unified cli effort to make sure the supported scaleout configuration is supported as intended. The instack-install-overcloud shouldn't have additional enhancements made if we are working on a replacement.

Comment 4 James Slagle 2015-05-26 17:47:04 UTC
(In reply to chris alfonso from comment #3)
> Jan, Please coordinate with the unified cli effort to make sure the
> supported scaleout configuration is supported as intended. The
> instack-install-overcloud shouldn't have additional enhancements made if we
> are working on a replacement.

s/instack-install-undercloud/instack-deploy-overcloud

Comment 6 Jan Provaznik 2015-06-16 12:25:55 UTC
In the new unified CLI there is a support for scaling out all of default roles including controllers:
https://github.com/rdo-management/python-rdomanager-oscplugin/blob/master/rdomanager_oscplugin/v1/overcloud_deploy.py#L459

So it's possible now to specify number of controller nodes with "--control-scale" argument when deploying overcloud.

Comment 9 Omri Hochman 2015-07-07 23:03:14 UTC
Verified with python-rdomanager-oscplugin-0.0.8-18.el7ost.noarch:

instack-deploy-overcloud is not in use anymore,  using the unified-cli we're sending '--control-scale 3' as part of the 'openstack overcloud deploy' like in the following example:  

Example: 
openstack overcloud deploy --plan-uuid 5eaecf2f-3c52-4fa7-b4a1-138d5822d83c --control-scale 3 --compute-scale 1 --ceph-storage-scale 1 --block-storage-scale 0 --swift-storage-scale 0 -e /home/stack/network-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml --network-cidr 172.16.17.0/24 --floating-ip-cidr 10.19.184.0/24
--floating-ip-start=10.19.184.101 --floating-ip-end=10.19.184.150 --bm-network-gateway=10.19.184.254

Comment 11 errata-xmlrpc 2015-08-05 13:50:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.