Bug 118172 - 4 * subscript out of range
Summary: 4 * subscript out of range
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-12 19:43 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-15 10:42:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-03-12 19:43:38 UTC
Description of problem:

I just tried to compile Fedora Core2 Test1 package e2fsprogs-1.35-4

The compiler said

1.

mkjournal.c(241): warning #175: subscript out of range

The source code is

        fs->super->s_jnl_blocks[16] = inode.i_size;

but

[root@localhost SPECS]# find ../BUILD/e2fsprogs-1.35/ -name \*.h
-print | xargs
grep s_jnl_blocks
../BUILD/e2fsprogs-1.35/lib/ext2fs/ext2_fs.h:   __u32  
s_jnl_blocks[16];      /* Backup of the journal inode */
[root@localhost SPECS]#

Looks like broken code to me.

2.

journal.c(242): warning #175: subscript out of range

Source code is

                        j_inode->i_ext2.i_size = sb->s_jnl_blocks[16];

Duplicate.

3.

journal.c(865): warning #175: subscript out of range

The source code is

                        sb->s_jnl_blocks[16] = inode.i_size;

Duplicate.

4.

logdump.c(217): warning #175: subscript out of range

The source code is

                        journal_inode.i_size = es->s_jnl_blocks[16];

Duplicate.

I'm surprised at so many duplicates. Someone working on serious low
level code in the Linux system doesn't know basic facts about C.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Thomas Woerner 2004-03-15 10:42:33 UTC
Fixed in rawhide in rpm e2fsprogs-1.35-7 or newer.


Note You need to log in before you can comment on or make changes to this bug.