Bug 118188 - rpmbuild vs rpm -ba
rpmbuild vs rpm -ba
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-12 17:18 EST by Daniel
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-12 19:15:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel 2004-03-12 17:18:23 EST
I'm a new redhat fedora user (experienced with debian).  I spent about an
hour this morning trying to figure out how to create an RPM.  The most
authoritative sources of information I found in the first 30 minutes say
use "rpm -ba <specfile>" however, as I'm sure you know, on Fedora, that
results in "-ba: unknown option".

Your webpage at:
http://fedora.redhat.com/participate/developers-guide/ch-rpm-building.html

says:
"This chapter attempts to discuss how to build RPMs so that the package
conforms to Fedora project standards. It does not attempt to explain
everything there is to know about RPM or building RPMs."

This is the only information I could find FROM REDHAT about building RPMs
in fedora.  I'm sure other info exists, but manpages and googling didn't
cut it.

I did find the answer at:
http://www.freax.be/wiki/index.php/Building%20rpm's%20for%20Fedora%20core%201

...that building rpms requires the rpm-build package and the rpmbuild
command.

It would be really helpful, since all previous experience seems to expect
"rpm -ba" to work without installing a different package:

- "rpm -ba" provided a hint that the interface had changed;
- the manpage for rpm made mention of it;
- that fedora's webpages mentioned it on a page found by googling for
"fedora building rpm";
- or, possibly, the functionality were even added back into RPM (as the
most minimal intrusion for the users).

Of course I'm sure there were good reasons for the change; but I figure
you'd like to know that less experienced users are going to be (or, are)
confused by it.  I hope you will take these comments in the manner in
which I try to provide them; constructively trying to help the open-source
software development process.

If it were possible, I would apprecite knowing whether this might lead to
any changes.

Thanks very much,
Comment 1 Leonard den Ottolander 2004-03-12 19:15:01 EST
rpm -ba used to be the way to build a srpm until RHL 7.3 or 8.0. In
RHL 8.0 or 9 this changed. You now require to use rpmbuild -ba to
build a srpm (or a spec file).

Please be so kind to ask these kind of questions on the fedora-list.
Docs around the internet do not always get updated instantly.

This is NOTABUG.
Comment 2 R P Herrold 2004-03-12 23:31:31 EST
http://www.rpm.org/hintskinks/rpmbuild/ has been in place since July 2002

On the website for rpm, and on the mailing list for rpm hosted by Red
Hat, and in the man page accompanying the rpm package, this is long
since documented.
Comment 3 Daniel 2004-03-17 01:23:04 EST
First off, yes I'm embarrassed to admit I didn't notice the content in
the RPM manpage.  I think I checked the manpage first; I must have
missed the pertinant part at the bottom about rpmbuild.  I apologize
for saying the contrary.

I will take your word that redhat's RPM list describes building RPMs 
well; the archive has been down since Friday when I started looking for 
information.  

But please permit me to comment on the first part of Russ's 
conmment. You said: "http://www.rpm.org/hintskinks/rpmbuild/ has been
in place since July 2002"

I didn't find this page in an hour of looking for info about building
RPMs, via google, and by browsing your pages.  I do recognize that
"documents around the internet do not always get updated instantly" -
but it seemed very difficult to find the right document on rpm.org
itself.  

From the front page; I first visited "RPM HowTo".  It refers to 'rpm -ba'.
Back to the front page.  I visited "Howto's".  It honestly did not occur
to me to visit "The Fight" to find what I was looking for.  The other
howtos are either the one I already looked at, or mandrake specific.

Back to the front page.  I wasn't looking for kinks- that sounded like
a distraction...  The first link: "search".  Search for 'build rpm'.  
Looking just now, out of the first ten results, only the
ninth link gets the info I need; that was /howto/thefight/

If I may make a quick suggestion: relabel "The fight" from: 
"Matthias Saou goes head-to-head with tarballs" to "Matthias Saou's 
rpm package building introduction." - that would have gotten me to the
exact document I needed from the Howto page.

The "Hints and Kinks" name on the front page didn't suggest what I was
looking for; I wonder if the hints might be appropriately relabeled
and listed on the howtos page?

The reason I've gone to the trouble to write all this is assuredly not
to put down your and other developers', efforts; but to give a
perspective of a RPM-creating newbie.  I would like to give back if I
could; my suggestion on Hints and Kinks comes with an offer to come up
with additional wording suggestions, if you are interested.  

In any case I concur this is not a bug with fedora and am happy to
take my comments elsewhere (as needed).

Note You need to log in before you can comment on or make changes to this bug.