Bug 118199 - yum GLIBC Import Error
Summary: yum GLIBC Import Error
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-13 11:20 UTC by Pepe
Modified: 2014-01-21 22:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-19 10:02:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pepe 2004-03-13 11:20:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040115

Description of problem:
I dont know which package causes this error but it may be the *rpm*
Packages. I updated the System via yum and after this update i wasnt
able to start yum again.  It always crashes with this Error Message:

ImportError: /usr/lib/librpmio-4.3.so: symbol regexec, version
GLIBC_2.3.4 not defined in file libc.so.6 with link time reference

Is it possible that i updated the packages in the wrong order? Because
i used yum update r*, yum update s*, etc. because a complete yum
update would take too long.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Update to Current Version via yum update
2. Run yum
3.
    

Additional info:

Comment 1 Darin May 2004-03-19 03:22:55 UTC
I got this just after updating the rpm components and now I cant
downgrade.

Modiles installed:

rpm-devel-4.3-0.22
rpm-python-4.3-0.22
rpm-4.3-0.22
rpm-build-4.3-0.22

One of these seems to be the culprit.



Comment 2 Jeff Johnson 2004-03-19 10:02:46 UTC
Culprit? The missing symbols is in glibc,
and there is already a Requires: libc.so.6(GLIBC_2.3.4)
in the rpm package to ensure upgrade.

No matter what, glibc upgrade will fix.

Comment 3 Darin May 2004-03-19 15:42:00 UTC
Two questions:

1.  If there was a dependancy on a module not yet released, why did
yum proceede with the update?

2. Which of the glib module will? There are 13 of them.


Note You need to log in before you can comment on or make changes to this bug.