Bug 11820 - Relative symlinks in XFree86 specs
Summary: Relative symlinks in XFree86 specs
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-01 14:41 UTC by Idcmp
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-26 16:24:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Idcmp 2000-06-01 14:41:54 UTC
The symlinks for fs, twm, xdm, xinit, and xsm in /usr/X11R6/lib/X11, as
well as compiled in /usr/X11R6/lib/X11/xkb/ are relative symlinks:

lrwxrwxrwx   1 root     root           26 Dec  7 00:05 compiled ->  
../../../../../var/lib/xkb

etc..

This makes moving /usr or /usr/X11R6 onto a new drive (/newdrive/usr) and
symlinking ( -s /newdrive/usr /usr) break.  

The symlinks should be absolute paths to /etc/X11 and /var/lib/xkb.

Comment 1 Kevin - The Alchemist - Sonney 2000-06-17 19:24:59 UTC
When correcting this, you might also want to address the /etc/X11/X symlink as
well, as it points to ../../usr/X11R6/bin/<server>

Comment 2 Idcmp 2000-08-07 19:43:34 UTC
Will someone be looking at this for the upcoming rawhide?


Comment 3 Preston Brown 2000-09-11 18:07:06 UTC
the whole relative vs. absolute symlink thing has been beaten to death many
times.  Problems with absolute symlinks:

1. the break when the / partition is not actually mounted to /, i.e. in a
rescue-mode type configuration or something similar.

2. they often break when you are NFS-exporting a tree that contains them.

Problems with relative symlinks:

1. they make moving a subtree containing them difficult.

So there is really no way to win here.

Comment 4 Idcmp 2000-09-11 18:16:09 UTC
This bug isn't a discussion in general about symlinks.  It's two specific cases
where an absolute
symlink is needed, and it's 3 1/2 months old and likely too late to make it into
the forthcoming
release because of this huge delay.

Booting X in a rescue mode is absurd, and an absolute link to the configuration
for X does not break in the case where /usr/X11R6 would be NFS exported to other
machines as each would *want* its own configuration settings for X as that's
hardware dependant.



Comment 5 Mike A. Harris 2001-01-26 10:42:22 UTC
Changing from relative symlinks to absolute - as Preston indicated
solves one problem by creating another.  It boils down to the lesser of
two evils.  In this case, the "general" widespread usage of X is what
is most important.  Since few users are likely to move /usr to another
location in that manner, and many more are likely to be affected
poorly by changing to absolute links, this change is not going to happen.
Mounting the new drive/partition under /usr is one possible solution
for your problem.

Comment 6 Idcmp 2001-01-26 16:24:25 UTC
Well, let this bug serve as a documented warning to others who attempt to do
what I did.


Note You need to log in before you can comment on or make changes to this bug.