Bug 118205 - (4G/4G?) kernel broken Savage/IX-MV (MobileSavage) X-server
(4G/4G?) kernel broken Savage/IX-MV (MobileSavage) X-server
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 119462 (view as bug list)
Depends On:
Blocks: FC2Blocker FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-03-13 09:31 EST by Norbert Roma
Modified: 2015-01-04 17:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 00:00:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norbert Roma 2004-03-13 09:31:45 EST
Description of problem:
Updating from 2.6.3-1.118 to 2.6.3-2* (tried 240, 242, 246, 253)
breaks the X-server.  X comes up, but the image is severly distorted.
 Also, X-server complains about not being able to use bios.

Version-Release number of selected component (if applicable):
see above for kernel versions; the video controller is Savage/IX-MV,
MobileSavage, using XFree86 4.3.0-63.
The LCD on the laptop is 1400x1050 (I also tried 1280x1024 for
completeness); I tested 16 and 32 bpp

How reproducible:
Every time

Steps to Reproduce:
1.Boot any of the affected kernels into runlevel 5
2.
3.
  
Actual results:
Garbled image

Expected results:
Working X-server

Additional info:
Comment 1 Nitin Dahyabhai 2004-03-13 15:55:01 EST
I get the same problem, only no image at all.
Comment 2 Warren Togami 2004-04-10 22:21:16 EDT
Just a hunch, please try the latest rawhide i686 and i586 kernels and
report if the behavior is different in any way.
Comment 3 Ling Li 2004-04-14 19:14:07 EDT
The same here, with a IBM Thinkpad T23. Severl kernels before kernel
2.6.5-1.308 didn't work (no image at all); 2.6.5-1.308 works well;
2.6.5-1.315 and 2.6.5-1.322 don't, again. SELINUX is on (permissive)
all the time.
Comment 4 Warren Togami 2004-04-14 20:04:51 EDT
Is behavior any different between the i586 and i686 kernels of the
same version?
Comment 5 Ling Li 2004-04-14 20:26:57 EDT
Your are right. I tried 2.6.5-1.322.i586 and X works! Wrong
optimization in i686?
Comment 6 Mike A. Harris 2004-04-14 20:34:28 EDT
4G/4G split is a suspect
Comment 7 Warren Togami 2004-04-14 21:30:51 EDT
http://people.redhat.com/wtogami/temp/
Just to be 100% sure that we have isolated this problem to 4G/4G,
please test with this kernel.  This is i686 with zero changes except
4G/4G disabled.
Comment 8 Ling Li 2004-04-14 23:17:48 EDT
The one with 4G/4G disabled works. (I didn't have the hardware to test
the smp kernel but the up one works.) By the way, two unknown symbols 

/lib/modules/2.6.5-1.322.disabled4G/unsupported/fs/reiserfs/reiserfs.ko
needs unknown symbol sleep_on
/lib/modules/2.6.5-1.322.disabled4G/kernel/drivers/net/typhoon.ko
needs unknown symbol direct_csum_partial_copy_generic
Comment 9 David Carrigan 2004-04-15 01:37:50 EDT
*** Bug 119462 has been marked as a duplicate of this bug. ***
Comment 10 Colin Charles 2004-05-06 01:45:29 EDT
This used to affect me as I have a Thinkpad T20, and now, sleep works.
Kernel 2.6.5-1.327 from the standard test3 cd works.

I've just updated to the latest rawhide tree available today, and even
kernel 2.6.5-1.350 works like a charm. Looks like the bug has been fixed.
Comment 11 Ling Li 2004-05-10 04:29:25 EDT
I can confirm that kernel-smp 2.6.5-1.350.i686 & 351.i686 also work
for IBM Thinkpad T23. Display is back to normal.

Note You need to log in before you can comment on or make changes to this bug.