Bug 1182156 - Offline upgrade broken when repo gpg keys are not imported
Summary: Offline upgrade broken when repo gpg keys are not imported
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-14 14:25 UTC by Kamil Páral
Modified: 2015-01-17 05:37 UTC (History)
3 users (show)

Fixed In Version: libhif-0.1.7-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-15 12:55:00 UTC
Type: Bug


Attachments (Terms of Use)
failed update notification (247.73 KB, image/png)
2015-01-14 14:25 UTC, Kamil Páral
no flags Details
failed update notification - detail (277.81 KB, image/png)
2015-01-14 14:25 UTC, Kamil Páral
no flags Details
rpm -qa output (45.05 KB, text/plain)
2015-01-14 14:33 UTC, Kamil Páral
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1182090 None CLOSED gnome-software is stuck in a loop when trying to install an app without having repo gpg keys imported 2019-09-18 11:04:48 UTC

Internal Links: 1182090

Description Kamil Páral 2015-01-14 14:25:19 UTC
Created attachment 980037 [details]
failed update notification

Description of problem:
Similarly to bug 1182090, I tried an offline update on a Workstation that was installed from netinst, i.e. in an environment where the yum repo gpg keys were not imported by default. It fails, look at the attached screenshots to see what the user sees.

In system journal, I see this:

Jan 14 13:34:46 localhost.localdomain dbus[605]: [system] Activating via systemd: service name='org.freedesktop.
Jan 14 13:34:46 localhost.localdomain PackageKit[614]: daemon start
Jan 14 13:34:46 localhost.localdomain dbus[605]: [system] Activating via systemd: service name='org.freedesktop.
Jan 14 13:34:46 localhost.localdomain polkitd[618]: Started polkitd version 0.112
Jan 14 13:34:46 localhost.localdomain polkitd[618]: Loading rules from directory /etc/polkit-1/rules.d
Jan 14 13:34:46 localhost.localdomain polkitd[618]: Loading rules from directory /usr/share/polkit-1/rules.d
Jan 14 13:34:46 localhost.localdomain polkitd[618]: Finished loading, compiling and executing 5 rules
Jan 14 13:34:46 localhost.localdomain dbus[605]: [system] Successfully activated service 'org.freedesktop.Policy
Jan 14 13:34:46 localhost.localdomain polkitd[618]: Acquired the name org.freedesktop.PolicyKit1 on the system b
Jan 14 13:34:46 localhost.localdomain dbus[605]: [system] Activating via systemd: service name='org.freedesktop.
Jan 14 13:34:46 localhost.localdomain dbus[605]: [system] Successfully activated service 'org.freedesktop.Packag
Jan 14 13:34:46 localhost.localdomain dbus[605]: [system] Successfully activated service 'org.freedesktop.login1
Jan 14 13:34:46 localhost.localdomain systemd-logind[625]: New seat seat0.
Jan 14 13:34:46 localhost.localdomain systemd-logind[625]: Watching system buttons on /dev/input/event0 (Power B
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status wait
Jan 14 13:34:46 localhost.localdomain PackageKit[614]: uid 0 is trying to obtain org.freedesktop.packagekit.pack
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status waiting-for-auth
Jan 14 13:34:46 localhost.localdomain PackageKit[614]: new update-packages transaction /10_adaeaacc scheduled fr
Jan 14 13:34:46 localhost.localdomain PackageKit[614]: uid 0 obtained auth for org.freedesktop.packagekit.packag
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status wait
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status setup
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status query
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: percentage 0%
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status loading-cache
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status download-repository
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: percentage 4%
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status loading-cache
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status download-repository
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: percentage 8%
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: percentage 9%
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: percentage 10%
Jan 14 13:34:46 localhost.localdomain PackageKit[614]: update-packages transaction /10_adaeaacc from uid 0 finis
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: status finished
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: writing failed results
Jan 14 13:34:46 localhost.localdomain kernel: nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
Jan 14 13:34:46 localhost.localdomain pk-offline-update[590]: failed to update system: Failed to find gnutls;3.3
Jan 14 13:34:46 localhost.localdomain kernel: ip6_tables: (C) 2000-2006 Netfilter Core Team
Jan 14 13:34:46 localhost.localdomain kernel: Ebtables v2.0 registered
Jan 14 13:34:46 localhost.localdomain kernel: Bridge firewalling registered
Jan 14 13:34:57 localhost.localdomain pk-offline-update[590]: rebooting
Jan 14 13:34:57 localhost.localdomain pk-offline-update[590]: sent mode to plymouth 'shutdown'
Jan 14 13:34:57 localhost.localdomain pk-offline-update[590]: sent msg to plymouth 'Rebooting after installing u
Jan 14 13:34:57 localhost.localdomain systemd[1]: Shutting down.
Jan 14 13:34:57 localhost.localdomain alsactl[587]: alsactl daemon stopped
Jan 14 13:34:57 localhost.localdomain systemd-journal[476]: Journal stopped
-- Reboot --


Similarly to bug 1182090, I tried to work around this by running yum install first and importing the gpg key. But it doesn't help, the offline upgrade still fails. Maybe the keys need to be imported somewhere else as well, so that it's available during the offline upgrade boot? No idea.

I also attach file listings of important PackageKit directories, so that you see the contents, in case something is wrong in there.

$ find /var/lib/PackageKit/
/var/lib/PackageKit/
/var/lib/PackageKit/prepared-update
/var/lib/PackageKit/transactions.db

$ find /var/cache/PackageKit/
/var/cache/PackageKit/
/var/cache/PackageKit/hawkey
/var/cache/PackageKit/hawkey/updates.solv
/var/cache/PackageKit/hawkey/updates-filenames.solvx
/var/cache/PackageKit/hawkey/updates-updateinfo.solvx
/var/cache/PackageKit/hawkey/@System.solv
/var/cache/PackageKit/hawkey/fedora.solv
/var/cache/PackageKit/hawkey/hawkey.log
/var/cache/PackageKit/hawkey/fedora-filenames.solvx
/var/cache/PackageKit/downloads
/var/cache/PackageKit/metadata
/var/cache/PackageKit/metadata/fedora.tmp
/var/cache/PackageKit/metadata/updates
/var/cache/PackageKit/metadata/updates/packages
/var/cache/PackageKit/metadata/updates/packages/gnutls-3.3.11-2.fc21.x86_64.rpm
/var/cache/PackageKit/metadata/updates/packages/libvisio-0.1.1-1.fc21.x86_64.rpm
/var/cache/PackageKit/metadata/updates/packages/libodfgen-0.1.3-1.fc21.x86_64.rpm
/var/cache/PackageKit/metadata/updates/packages/gnutls-utils-3.3.11-2.fc21.x86_64.rpm
/var/cache/PackageKit/metadata/updates/packages/nfs-utils-1.3.1-4.1.fc21.x86_64.rpm
/var/cache/PackageKit/metadata/updates/packages/gnutls-dane-3.3.11-2.fc21.x86_64.rpm
/var/cache/PackageKit/metadata/updates/packages/libvdpau-0.9-1.fc21.x86_64.rpm
/var/cache/PackageKit/metadata/updates/repodata
/var/cache/PackageKit/metadata/updates/repodata/2d74ba082b274e1fec67eefb278d7a40232af04208f20a2665edeeddf8cb0f52-comps-f21.xml
/var/cache/PackageKit/metadata/updates/repodata/repomd.xml
/var/cache/PackageKit/metadata/updates/repodata/f7eb3e41c0c0c62dd3db61f39780709ed69d4bcb4f994295cb7e04bf3f382914-filelists.xml.gz
/var/cache/PackageKit/metadata/updates/repodata/63f36d164f1ce87326e80dd9e24c3e054502c246bd8a3651f0a4d0b8da5691ae-updateinfo.xml.gz
/var/cache/PackageKit/metadata/updates/repodata/32a72db14f1acd7fd6475cbc405e2f0405b5c162e2142541b69419e8c4a43cec-primary.xml.gz
/var/cache/PackageKit/metadata/updates/metalink.xml
/var/cache/PackageKit/metadata/fedora
/var/cache/PackageKit/metadata/fedora/repodata
/var/cache/PackageKit/metadata/fedora/repodata/abb4ea5ccb9ad46253984126c6bdc86868442a4662dbcfa0e0f51b1bb209331e-filelists.xml.gz
/var/cache/PackageKit/metadata/fedora/repodata/repomd.xml
/var/cache/PackageKit/metadata/fedora/repodata/3d0ff0dc90054cc48a84162e996e612371a8a135573db9a33efd953aa1502603-comps-f21.xml
/var/cache/PackageKit/metadata/fedora/repodata/e2a28baab2ea4632fad93f9f28144cda3458190888fdf7f2acc9bc289f397e96-primary.xml.gz
/var/cache/PackageKit/metadata/fedora/metalink.xml
/var/cache/PackageKit/metadata/updates.tmp


Version-Release number of selected component (if applicable):
gnome-software-3.14.2-2.fc21.x86_64
gnome-packagekit-3.14.2-1.fc21.x86_64
PackageKit-1.0.3-4.fc21.x86_64
PackageKit-cached-metadata-1.0.3-4.fc21.x86_64
PackageKit-command-not-found-1.0.3-4.fc21.x86_64
PackageKit-glib-1.0.3-4.fc21.x86_64
PackageKit-gstreamer-plugin-1.0.3-4.fc21.x86_64
PackageKit-gtk3-module-1.0.3-4.fc21.x86_64
fedora-repos-21-2.noarch

How reproducible:
always


Steps to Reproduce:
1. use F21 Server netinst to install Workstation
2. boot the system
3. wait until some updates become available. Alternatively, enabling updates-testing should work as well.
4. see "updates available" notification
5. reboot into offline upgrade
6. after the system boots again, wait for post-upgrade notification
7. see that it failed
8. import the gpg keys using yum install something
9. try offline upgrade again
10. see that it failed again

Actual results:
offline upgrade doesn't work when the system doesn't have repo gpg keys imported

Expected results:
offline upgrade works when the system doesn't have repo gpg keys imported, e.g. asks before reboot, or at least provides some reasonable warning instead of suggesting reboot (and then bug 748320 can become a blocker as a prerequisite)

Additional info:
It's also possible that the error is not related to missing gpg keys, but it's a different issue. I don't know how to verify that. Those gpg keys seem to be the most probable cause, though.

Comment 1 Kamil Páral 2015-01-14 14:25:46 UTC
Created attachment 980038 [details]
failed update notification - detail

Comment 2 Kamil Páral 2015-01-14 14:33:43 UTC
Created attachment 980042 [details]
rpm -qa output

libhif-0.1.7-1.fc21.x86_64
rpm-4.12.0.1-4.fc21.x86_64

Comment 3 Fedora Update System 2015-01-15 09:00:01 UTC
libhif-0.1.7-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libhif-0.1.7-2.fc21

Comment 4 Kamil Páral 2015-01-15 12:55:00 UTC

*** This bug has been marked as a duplicate of bug 1181501 ***

Comment 5 Fedora Update System 2015-01-17 05:37:53 UTC
libhif-0.1.7-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.