Bug 1182184 - reduced installation footprint for minimal pcp applications
Summary: reduced installation footprint for minimal pcp applications
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pcp
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1184403 (view as bug list)
Depends On:
Blocks: 1185740
TreeView+ depends on / blocked
 
Reported: 2015-01-14 14:56 UTC by Frank Ch. Eigler
Modified: 2015-08-22 16:34 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-08-13 16:57:01 UTC


Attachments (Terms of Use)

Description Frank Ch. Eigler 2015-01-14 14:56:51 UTC
Some pcp clients are happy to use PM_CONTEXT_LOCAL with a small handful 
of C .so PMDA's (linux_proc e.g.), but are unhappy that these pmdas are
only packaged in the central 'pcp' rpm, which has perl/python/etc.
prerequisites.  We should break up the 'pcp' rpm so that the footprint
for small clients is small.

- the default pmns/root is either not used at all, or is provided in
  generated capacity by the build, instead of being generated during
  first -pmcd- startup

- pmdas that need perl are separated out into at least one subrpm;
  likewise python

- plain C (no-further-big-prereqs) pmdas are separated out
  into at least one subrpm (without depending on base pcp)

- if needed, libpcp adjusted PM_CONTEXT_LOCAL can use the pmda
  subrpms without needing other pcp binaries / nontrivial config
  files

- probably: invent a mechanism where libpcp can find .so pmdas
  by searching the pmda directories rather than scraping pmcd.conf,
  e.g., a __pmSpecLocalPMDA keyword "scan", searching $PMDADIR and
  stdpmid.pcp / stdpmid.local?

(This should also shrink the hurdles for a default-on local-pmlogger
installation.)

Comment 1 Frank Ch. Eigler 2015-01-21 12:27:42 UTC
*** Bug 1184403 has been marked as a duplicate of this bug. ***

Comment 2 Nathan Scott 2015-01-23 01:52:11 UTC
Other places where improvements should be made:

- remove the direct dependency in libpcp on the Avahi libraries - all discovery/advertising methods should become runtime configurable and extensible outside of PCP.

- remove the direct dependency in libpcp on NSS/SSL, Dave has completed almost all of the work for this now - someone just needs to go the last dlopen step.

- pmwebd seems to have acquired a dependency chain that includes some 10-15 X11/desktop/font libraries, and associated rpm dependencies, as a result of using the Cairo library.  Its resident memory footprint has doubled as a result, combined with the switch to using C++ - would be worth considering a more dynamic plugin model for pmwebd, as people will want to use it on servers without all those X11 rpms.

The "invent a mechanism" line in original report wont fly as described I suspect - IIRC pmcd.conf was used because these PMDAs are known to have root namespace entries, which is required in local context mode also - so a design which considers the metric namespace would be needed.

Comment 3 Frank Ch. Eigler 2015-01-23 02:32:48 UTC
Apprx. all those libraries are already split into separate -libs type
subrpms, so beyond their genuinely useful function do not constitute
unnecessary or peculiar overheads.  One should need a pretty well-justified
case to justify reinventing ordinary dynamic linking.

Comment 4 Jaroslav Reznik 2015-03-03 16:42:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 5 Fedora Update System 2015-06-16 02:12:32 UTC
pcp-3.10.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/pcp-3.10.5-1.fc22

Comment 6 Fedora Update System 2015-06-16 02:13:44 UTC
pcp-3.10.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pcp-3.10.5-1.fc21

Comment 7 Fedora Update System 2015-06-16 02:14:33 UTC
pcp-3.10.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pcp-3.10.5-1.fc20

Comment 8 Fedora Update System 2015-06-16 02:16:39 UTC
pcp-3.10.5-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/pcp-3.10.5-1.el5

Comment 9 Fedora Update System 2015-06-18 18:34:42 UTC
Package pcp-3.10.5-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing pcp-3.10.5-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-6718/pcp-3.10.5-1.el5
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-08-04 05:37:46 UTC
pcp-3.10.6-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/pcp-3.10.6-1.fc22

Comment 11 Fedora Update System 2015-08-04 05:38:30 UTC
pcp-3.10.6-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pcp-3.10.6-1.fc21

Comment 12 Fedora Update System 2015-08-04 05:39:09 UTC
pcp-3.10.6-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/pcp-3.10.6-1.el5

Comment 13 Frank Ch. Eigler 2015-08-04 15:41:24 UTC
Not a huge deal, but this bug shouldn't be considered fixed when associated with OS versions where the pcp -> pcp-compat -> pcp-mostly-everything dependency chain is active.

Comment 14 Fedora Update System 2015-08-13 16:57:01 UTC
pcp-3.10.6-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-08-13 16:58:41 UTC
pcp-3.10.6-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2015-08-22 16:33:49 UTC
pcp-3.10.6-1.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.