Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 118223 - Audio mixer lost after switching desktops
Audio mixer lost after switching desktops
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-13 16:30 EST by Dean Sands
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 18:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Sands 2004-03-13 16:30:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a)
Gecko/20040218

Description of problem:
I had an installation of Redhat earlier (9, I think) last year that
gave me this same error. My sound device is identified SiS PCI Audio
Accelerator.
However, the mixer settings are gone. This happened after I switched
from Gnome to KDE and back again. I loaded two daemons: lisa and smb.
Removing them has not fixed the error. According to the Soundcard
Detection, I have a sound device. However, the system is unable to
open /dev/mixer.I have located the file. It is a zero-length
character-device file with read/write permissions. I've also located a
second file "mixer1" that is apparently the same.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Linux
2.Run Linux
3.Enjoy Linux
4.Switch to KDE
5. Enjoy Linux
6. Switch back to Gnome
7. Hate Linux
8. Go back to Windows


Additional info:
This is the reason I dropped Redhat in the first place. Ironically,
and I really hate to say this, I've never had any problems on this
machine with the sound OR the video driver with Windows.
Comment 1 Brent Fox 2004-03-17 13:44:36 EST
When you say the "mixer settings are gone" do you mean that the panel
volume control has disappeared or have you lost the ability to play
sound at all?
Comment 2 Dean Sands 2004-03-17 23:40:04 EST
Yeah, sorry about the attitude. No music can make a guy cranky. What 
happened was I lost sound altogether. Somehow in changing desktops 
from Gnome to KDE (I have better luck Samba-ing) with KDE, the mixer 
settings file got moved or deleted. I noticed that come up during 
shut-down. Hence, I had no sound because the mixer didn't know what 
to do. I rebooted normally with KDE as the default. It came up. My 
sound was back. But I don't have a speaker icon. Is that supposed to 
be in KDE? Can't remember. I haven't been in Gnome for a while. I'll 
see what happens when I switch back.
Comment 3 Brent Fox 2004-04-13 18:37:07 EDT
I do not believe that KDE has the volume control in the panel by
default.  Please reopen this bug if the volume control has disappeared
from the Gnome panel.

Note You need to log in before you can comment on or make changes to this bug.