Bug 1182563 - Require ioprocess 0.14
Summary: Require ioprocess 0.14
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Yeela Kaplan
QA Contact: Elad
URL:
Whiteboard: infra
Depends On:
Blocks: 1180899
TreeView+ depends on / blocked
 
Reported: 2015-01-15 13:18 UTC by Yeela Kaplan
Modified: 2016-02-10 19:10 UTC (History)
11 users (show)

Fixed In Version: vdsm-4.16.8.1-6.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-15 09:14:34 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0227 normal SHIPPED_LIVE vdsm 3.5.0-1 ASYNC - bug fix and enhancement update 2015-02-16 19:40:04 UTC
oVirt gerrit 34403 None None None Never
oVirt gerrit 36963 ovirt-3.5 MERGED spec: require latest version of IOProcess Never

Description Yeela Kaplan 2015-01-15 13:18:06 UTC
Description of problem:
IOprocesses that should be closed remain in the system because they are being referenced by the ioprocess communication thread.

version 0.14 of ioprocess fixes this issue.


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Elad 2015-01-20 17:07:40 UTC
ioprocess is closed when the file domain is deactivated and detached.

Verified using rhev 3.5 vt13.8
vdsm-4.16.8.1-6.el6ev.x86_64
ioprocess-0.14.0-3.el6ev.x86_64

Comment 4 Eyal Edri 2015-02-15 09:14:34 UTC
bugs were moved by ERRATA to RELEASE PENDING bug not closed probably due to errata error.
closing as 3.5.0 is released.


Note You need to log in before you can comment on or make changes to this bug.