Bug 1182565 - Chart that displays facts for all hosts needs a header
Summary: Chart that displays facts for all hosts needs a header
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Sanket Jagtap
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-15 13:21 UTC by David O'Brien
Modified: 2019-09-26 17:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:46:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 9006 None None None 2016-04-22 15:45:29 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description David O'Brien 2015-01-15 13:21:11 UTC
Description of problem:

If you navigate to the "Facts" page for a host, on the right side there is a "Chart" button that displays a circular plot of the distribution of the selected fact over ALL hosts.

This is not obvious by the button label or by the chart that appears.

Version-Release number of selected component (if applicable):

Version 6.0.4 © 2014 Red Hat Inc.

How reproducible:

Always.

Steps to Reproduce:
1. Hosts > All Hosts
2. Click any host in the list and click "Facts"
3. On the right side, click Chart

Actual results:

A new window with a "Fact Chart" displays, but it's not obvious what it's about.

Expected results:

A tooltip that says "Display distribution of this fact for all hosts" or something similar would be nice.

The window itself should have a header describing the chart, e.g., "Distribution of Fact $fact_name Across all Hosts"

Additional info:

Comment 1 RHEL Program Management 2015-01-15 13:23:59 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2015-01-16 16:13:19 UTC
Created redmine issue http://projects.theforeman.org/issues/9006 from this bug

Comment 4 Bryan Kearney 2015-01-18 15:05:10 UTC
Upstream bug assigned to szadok@redhat.com

Comment 5 Bryan Kearney 2015-02-11 13:04:50 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9006 has been closed
-------------
Shlomi Zadok
Applied in changeset commit:f5975f9490749ee35f204f49f3bd92069e47c414.

Comment 8 Sanket Jagtap 2016-04-22 10:35:31 UTC
The window now has a header describing the chart, e.g., "Fact distribution chart - $fact_name (no. of hosts)"

Comment 10 errata-xmlrpc 2016-07-27 08:46:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.