Bug 1182635 - Add PRIVACY_POLICY_URL to /etc/os-release
Summary: Add PRIVACY_POLICY_URL to /etc/os-release
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F22FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-01-15 15:40 UTC by Bastien Nocera
Modified: 2015-05-21 18:45 UTC (History)
9 users (show)

Fixed In Version: fedora-release-22-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-21 18:44:13 UTC


Attachments (Terms of Use)
control center (482.21 KB, image/png)
2015-05-15 12:44 UTC, Kamil Páral
no flags Details
gnome initial setup (42.19 KB, image/png)
2015-05-15 12:45 UTC, Kamil Páral
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1149568 None CLOSED /etc/os-release should be a symlink to /usr/lib/os-release 2019-01-15 10:54:13 UTC
Red Hat Bugzilla 1222473 None NEW privacy policy for the distribution 2019-01-15 10:54:13 UTC

Internal Links: 1149568 1222473

Description Bastien Nocera 2015-01-15 15:40:30 UTC
Newer versions of systemd have defined the PRIVACY_POLICY_URL property which can be added to /etc/os-release:
http://cgit.freedesktop.org/systemd/systemd/commit/?id=ed9e8bf66d1b3a00aa7fb6d57ec89dd8a3b8d7dc

This will be used in gnome-control-center's Privacy settings, with regards to how data is used by the retrace server:
https://bugzilla.gnome.org/show_bug.cgi?id=742375

Note that Matthias Clasen is discussing 1) the content 2) the URL to be used for this.

Comment 1 Zbigniew Jędrzejewski-Szmek 2015-01-31 17:06:56 UTC
So, what's the status here?

Is it PRIVACY_POLICY=https://fedoraproject.org/wiki/Legal:PrivacyPolicy ? Can we proceed with that?

Comment 2 Matthias Clasen 2015-02-02 12:41:13 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #1)
> So, what's the status here?
> 
> Is it PRIVACY_POLICY=https://fedoraproject.org/wiki/Legal:PrivacyPolicy ?
> Can we proceed with that?

I think that is safe to put in now. I expect that the discussion of the privacy policy on legal@lists.fedoraproject.org might result in changes (improvements!) of the content, but not the url.

Comment 3 Matthias Clasen 2015-02-08 14:40:47 UTC
Zbigniew, will you add this ?

Comment 4 Peter Robinson 2015-02-10 17:03:51 UTC
Committed upstream, will be in F-22/F-23 shortly once we've finished the branch

Comment 5 Bastien Nocera 2015-02-11 09:23:29 UTC
I'll reopen because https://fedoraproject.org/wiki/Legal:PrivacyPolicy really isn't a satisfactory link.

If I was a user of Fedora reading this, I would read:
"
Fedora collects personal information when:

you create a user account;
"

What? Well, when you create an account in the Fedora system.

This link is inappropriate for Fedora, the software.

Comment 6 Peter Robinson 2015-02-11 09:26:35 UTC
(In reply to Bastien Nocera from comment #5)
> I'll reopen because https://fedoraproject.org/wiki/Legal:PrivacyPolicy
> really isn't a satisfactory link.

Are you opposed to the actual technical URL or the contents of it?

Comment 7 Bastien Nocera 2015-02-11 09:31:53 UTC
(In reply to Peter Robinson from comment #6)
> (In reply to Bastien Nocera from comment #5)
> > I'll reopen because https://fedoraproject.org/wiki/Legal:PrivacyPolicy
> > really isn't a satisfactory link.
> 
> Are you opposed to the actual technical URL or the contents of it?

What's "an actual technical URL"? I don't care what it links to, the link itself isn't going to show in the UI, but the content is wholly inappropriate as the privacy policy for an OS.

Comment 8 Peter Robinson 2015-02-11 09:45:50 UTC
(In reply to Bastien Nocera from comment #7)
> (In reply to Peter Robinson from comment #6)
> > (In reply to Bastien Nocera from comment #5)
> > > I'll reopen because https://fedoraproject.org/wiki/Legal:PrivacyPolicy
> > > really isn't a satisfactory link.
> > 
> > Are you opposed to the actual technical URL or the contents of it?
> 
> What's "an actual technical URL"? I don't care what it links to, the link
> itself isn't going to show in the UI, but the content is wholly
> inappropriate as the privacy policy for an OS.

As in https://fedoraproject.org/wiki/Legal:PrivacyPolicy VS http://some/other/url

This bug isn't about the content of what's to be displayed, this is about getting a specific field added to the os-release file and a URL added to that. The actual contents of what that URL displays is the responsibility of the Fedora Council and Legal. That's not something that gets fixed here, this bug is purely a technical implementation of a change for the fedora-release package.

I suggest you start the discussion oh the council-discuss list or open up a ticket in legal/council for the contents of the actual page to be displayed

Comment 9 Dennis Gilmore 2015-02-11 10:05:07 UTC
To reiterate what Peter said. This bug asked us to add the PRIVACY_POLICY field we have done so and pointed it at the url that was suggested by Zbigniew and acked by Matthias. Matthias did say that the content at that location was still being worked on. The content at the link is outside of anything releng has any control over.  If it ends up that a different url is needed then open a bug at that time and we will update the url in the /usr/lib/os-release file. This bug however is fixed.

Comment 10 Bastien Nocera 2015-02-11 10:25:24 UTC
(In reply to Peter Robinson from comment #8)
> (In reply to Bastien Nocera from comment #7)
> > (In reply to Peter Robinson from comment #6)
> > > (In reply to Bastien Nocera from comment #5)
> > > > I'll reopen because https://fedoraproject.org/wiki/Legal:PrivacyPolicy
> > > > really isn't a satisfactory link.
> > > 
> > > Are you opposed to the actual technical URL or the contents of it?
> > 
> > What's "an actual technical URL"? I don't care what it links to, the link
> > itself isn't going to show in the UI, but the content is wholly
> > inappropriate as the privacy policy for an OS.
> 
> As in https://fedoraproject.org/wiki/Legal:PrivacyPolicy VS
> http://some/other/url
> 
> This bug isn't about the content of what's to be displayed

Oh, my mistake for thinking I requested a link to the privacy policy of the OS, not of web services offered by Fedora.

Comment 11 Peter Robinson 2015-02-11 10:50:14 UTC
> > This bug isn't about the content of what's to be displayed
> 
> Oh, my mistake for thinking I requested a link to the privacy policy of the
> OS, not of web services offered by Fedora.

To quote from comment #2 above:

"I think that is safe to put in now. I expect that the discussion of the privacy policy on legal@lists.fedoraproject.org might result in changes (improvements!) of the content, but not the url."

Comment 12 Matthias Clasen 2015-02-11 18:14:10 UTC
Sadly, that discussion seems to have petered out. Spot made a suggestion for what to add to the policy, but nothing happened...

Comment 13 Bastien Nocera 2015-05-15 12:02:20 UTC
(In reply to Peter Robinson from comment #4)
> Committed upstream, will be in F-22/F-23 shortly once we've finished the
> branch

It's PRIVACY_POLICY_URL=
not PRIVACY_POLICY=

Comment 14 Bastien Nocera 2015-05-15 12:04:24 UTC
It breaks the links to the privacy policy from gnome-initial-setup and the GNOME Privacy settings.

Comment 15 Kamil Páral 2015-05-15 12:36:51 UTC
This only breaks a link in gnome-control-center (goes to https://www.gnome.org/privacy-policy , which is Not Found). The link from gnome-initial-setup goes correctly to https://fedoraproject.org/wiki/Legal:PrivacyPolicy .

That suggests a bug in gnome-initial-setup, which "circumvents" the bug in /etc/os-release.

If I edit /etc/os-release and change PRIVACY_POLICY to PRIVACY_POLICY_URL, gnome-control-center starts to work (goes to fedora wiki), but gnome-initial-setup link goes to https://location.services.mozilla.com/privacy . What?

Comment 16 Kamil Páral 2015-05-15 12:44:52 UTC
Created attachment 1025832 [details]
control center

For the purpose of blocker bug discussion, I attach screenshots of affected programs.

Comment 17 Kamil Páral 2015-05-15 12:45:27 UTC
Created attachment 1025833 [details]
gnome initial setup

Comment 18 Zbigniew Jędrzejewski-Szmek 2015-05-18 10:16:39 UTC
Yikes, it indeed should be PRIVACY_POLICY_URL, not PRIVACY_POLICY. I think we should fix /usr/lib/os-release to use the proper name immediately before it becomes more widely used.

Paul Frields had a draft ready. I'll file a separate bug for that.

Comment 19 Stephen Gallagher 2015-05-18 14:37:32 UTC
I'm not prepared to call this a blocker, as it doesn't violate any obvious criteria.

That being said, there's clear value in having this right on the install media and live images, so +1 Freeze Exception.

Comment 20 Paul W. Frields 2015-05-18 14:39:18 UTC
We are still waiting on results of legal review for the new policy, but it will indeed supersede the existing policy on the same URL. So that's the right URL to use.

Comment 21 Bastien Nocera 2015-05-18 14:46:36 UTC
(In reply to Kamil Páral from comment #15)
> This only breaks a link in gnome-control-center (goes to
> https://www.gnome.org/privacy-policy , which is Not Found).

It's just a placeholder.

> The link from
> gnome-initial-setup goes correctly to
> https://fedoraproject.org/wiki/Legal:PrivacyPolicy .
> 
> That suggests a bug in gnome-initial-setup, which "circumvents" the bug in
> /etc/os-release.

Bug in gnome-initial-setup:
https://bugzilla.gnome.org/show_bug.cgi?id=749545

> If I edit /etc/os-release and change PRIVACY_POLICY to PRIVACY_POLICY_URL,
> gnome-control-center starts to work (goes to fedora wiki), but
> gnome-initial-setup link goes to
> https://location.services.mozilla.com/privacy . What?

Different fallback.

Comment 22 Stephen Gallagher 2015-05-18 14:48:12 UTC
So am I correct in my interpretation that the only change that needs to be made here is to correct /etc/os-release from using PRIVACY_POLICY to using PRIVACY_POLICY_URL to align with upstream? If so, I'll submit a patch for Dennis to review.

Comment 23 Petr Schindler 2015-05-18 16:39:47 UTC
Discussed at today's blocker review meeting [1]. 

This bug was rejected as blocker bug accepted as freeze exception: This doesn't directly violate any criteria and thus, isn't blocking. However, it would be good to get these fixes in for g-i-s and /etc/os-release.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-18

Comment 24 Fedora Update System 2015-05-18 16:57:14 UTC
gnome-initial-setup-3.16.3-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-initial-setup-3.16.3-1.fc22

Comment 25 Matthias Clasen 2015-05-18 17:43:10 UTC
Reopening: We still need the fix for /etc/os-release. I've pushed a change to gnome-initial-setup to make it look for both PRIVACY_POLICY_URL and PRIVACY_POLICY.

Comment 26 Bastien Nocera 2015-05-19 11:00:50 UTC
(In reply to Matthias Clasen from comment #25)
> Reopening: We still need the fix for /etc/os-release. I've pushed a change
> to gnome-initial-setup to make it look for both PRIVACY_POLICY_URL and
> PRIVACY_POLICY.

We really shouldn't need to cover for bugs like this that happen *before release* and that are caused by release packages.

Comment 27 Dennis Gilmore 2015-05-19 14:19:53 UTC
the final fedora-release update that will be part of RC1 will have PRIVACY_POLICY_URL in it

Comment 28 Fedora Update System 2015-05-19 14:52:14 UTC
fedora-release-22-1,fedora-repos-22-1 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/fedora-release-22-1,fedora-repos-22-1

Comment 29 Fedora Update System 2015-05-20 02:54:21 UTC
Package fedora-release-22-1, fedora-repos-22-1:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-release-22-1 fedora-repos-22-1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8564/fedora-release-22-1,fedora-repos-22-1
then log in and leave karma (feedback).

Comment 30 Fedora Update System 2015-05-21 18:44:13 UTC
gnome-initial-setup-3.16.3-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2015-05-21 18:45:22 UTC
fedora-release-22-1, fedora-repos-22-1 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.