Bug 118268 - Error loading OS
Error loading OS
Status: CLOSED DUPLICATE of bug 115980
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
2
athlon Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-14 16:45 EST by Nick Zisk
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nick Zisk 2004-03-14 16:45:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I am running windows XP pro and Windows Server2003 on a multiboot 
system on the primary channel HDD. Installed fedora core 2 test1 on 
secondary channel HDD using grub boot loader for windows and linux.

Reboot and got a error loading OS message. Had to run FIXMBR in 
windows recovery console to repair damage that fedora did.

Version-Release number of selected component (if applicable):
Fedora Core 2 test1

How reproducible:
Always

Steps to Reproduce:
1.have xp and server os on a primary hdd
2. install linux on secondary drive use grub for multiboot have Xp be 
primary boot
3. reboot 
    

Actual Results:  ERROR loading OS

Additional info:
Comment 1 Jeremy Katz 2004-03-15 12:13:11 EST
What sort of "error loading OS" message?  Does your BIOS support
accessing the drive that you had Linux installed to?
Comment 2 Henri Ala-Peijari 2004-04-02 08:08:06 EST
I have the same problem with FC2-test2. 
This is what I get when I try to boot my WinXP (labeled "Other")

  Booting 'Other'
rootnoverify(hd0,0)
chainloader +1

The linux installed on secondary ide master boots and works ok. The
WinXP is on primary ide master drive (and worked fine before
installing FC2-Test2).
Comment 3 Bryan Culley 2004-04-05 20:54:37 EDT
Same message:

  Booting 'Other'

rootnoverify(hd0,0)
chainloader +1


Occurred with both test1 and test2 of fedora core 2.  (did not occur
with fedora core 1) Windows XP on primary, fedora on secondary with
grub installed on primary.
Comment 4 Zoltan Kota 2004-05-19 07:51:21 EDT
Same error after installing Core 2 final release:
"Error loading operating system"

Windows XP was installed on hda.
I added a new disk as hdc and installed FC2 on it. grub was installed on 
hdc; I wanted to boot fc2 by boot disk/CD.
Comment 5 Alan Cox 2004-05-21 20:59:25 EDT
Anaconda is corrupting partition tables in some cases it appears, even
when its not asked to touch them
Comment 6 Pedro Fernandes Macedo 2004-05-29 15:04:02 EDT
Bug #115980 is a duplicate of this one. On that bug report , there's a
extensive discussion about the problem. Maybe it contains usefull
information.
Comment 7 Jarrod Porter 2004-06-10 00:06:24 EDT
I also had this problem, It looks like fedora some how messed up the 
way the system bios looks at the hard drives. The Solution is to set 
the harddrive type to LBA. I don't know how fedora could have messed 
with the bios, but thats what it looks like.
Comment 8 Jeremy Katz 2004-06-21 19:07:55 EDT

*** This bug has been marked as a duplicate of 115980 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:01:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.