Bug 11827 - Error detected while processing BufReadPost Auto commands for "*":
Error detected while processing BufReadPost Auto commands for "*":
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
6.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-01 13:21 EDT by scot
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-01 13:21:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scot 2000-06-01 13:21:13 EDT
Occassionally, when opening a file with vim I get this message:

Error detected while processing BufReadPost Auto commands for "*":
Mark has invalid line number
Press RETURN or enter command to continue

If I press enter, vim opens the file and everything appears to function
normally.  Curious what this actually means and if there's potential to
corrupt the file.

# rpm -qa | grep vim
vim-minimal-5.6-11
vim-enhanced-5.6-11
vim-common-5.6-11

here's my .vimrc:
--------cut here------
set ruler
set showmatch
set showmode
set title
set visualbell
set nohlsearch
syntax on

" SWJ 092199 syntax hilighting didn't work--found this at
" found this gem at http://www.vim.org/vimrc (see Sven's vimrc link)
"
" Set the colors for vim on "xterm"
if &term=="xterm"
  set t_Co=8
  set t_AB=%p1%{8}%<%t%p1%{40}%+%e%p1%{92}%+%;%dm
  set t_AF=%p1%{8}%<%t%p1%{30}%+%e%p1%{82}%+%;%dm
endif
--------cut here------
Comment 1 Bernhard Rosenkraenzer 2000-06-17 12:06:02 EDT
It's not a bug, it's a feature.
vim remembers the last line you edited in a file and goes back to that line.
If you delete the file and put in a file with fewer lines (or if you remove some
lines using a different editor), vim can't go to the line it remembered, and
that's what this error message complains about.

Note You need to log in before you can comment on or make changes to this bug.