Bug 1182816 - Touchpad wont work with Asus TP500LA 360-degree flipping touchscreen panel.
Summary: Touchpad wont work with Asus TP500LA 360-degree flipping touchscreen panel.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-16 01:19 UTC by JonRam
Modified: 2015-05-20 07:47 UTC (History)
24 users (show)

Fixed In Version: kernel-4.0.2-300.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-11 19:03:10 UTC


Attachments (Terms of Use)
patched psmouse (410.68 KB, application/x-gzip)
2015-05-05 22:06 UTC, George Moutsopoulos
no flags Details
patch for kernels 3.16-4.0 (2.32 KB, patch)
2015-05-05 22:08 UTC, George Moutsopoulos
no flags Details | Diff

Description JonRam 2015-01-16 01:19:23 UTC
Description of problem:
Touchscreen works fine, and attaching a USB mouse also works, but the touchpad doesn't work at all and you can see the following message in journalctl: "psmouse serio4: TouchPad at isa0060/serio4/input0 lost sync at byte 6".

This happens every time you try to use the touchpad.

Version-Release number of selected component (if applicable):
Elantech hardware version 4 (with firmware version 0x381f17)

How reproducible:
Always.

Steps to Reproduce:
1.Turn on laptop.
2.Logon to Desktop OS by using the touchscreen or mouse.
3.Try using the touchpad.

Actual results:
Touchpad wont work and displays a "lost sync" error in journalctl.

Expected results:
Touchpad working together with touchscreen and/or USB mouse.

Additional info:
Symptoms seem like if the laptop is in constant tablet mode.

Comment 1 Justin M. Forbes 2015-01-27 15:01:14 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 21 kernel bugs.

Fedora 21 has now been rebased to 3.18.3-201.fc21.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 2 JonRam 2015-01-29 17:30:44 UTC
This bug's still present, nothing changed at all.

Thanks for the update.

Comment 3 George Moutsopoulos 2015-03-10 18:39:46 UTC
JonRam, I have the same problems with ubuntu 14.10 kernels 3.16 up to 3.19. no solution (the mouse works only as a point and click with proto=imps option in psmouse module).
Possibly related reports you might want to keep an eye on
https://bugzilla.kernel.org/show_bug.cgi?id=48161
and
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442/+index?comments=all
But I can't find any solution in any of these.

My model is TP500LN and elantech hardware id is ETD0108. Main warning in dmesg is "lost sync at byte 6". Good luck!

Comment 4 JonRam 2015-03-23 18:03:28 UTC
Thanks George.

They found a solution here:
https://bugzilla.kernel.org/show_bug.cgi?id=84491

"
>Ulrik De Bie 2015-03-19 20:11:20 UTC
>
>A workaround has already been found for this:
>
>echo 1 > /sys/devices/platform/i8042/serio4/reg_07
>
>The kernel drivers writes this 1 to reg_07 during initialisation, but magically >it changes back to 0.
>
>This workaround seems to work until a suspend2ram/disk.
"

Hope they can fix it for next kernel upgrade.

Cheers.

Comment 5 George Moutsopoulos 2015-04-01 20:19:16 UTC
Thanks!
For at least asus TP500LN a kernel patch is under consideration
https://bugzilla.kernel.org/show_bug.cgi?id=84491
https://www.marc.info/?t=142731893400011
The second link has a patch that works on my laptop.

Comment 6 Fedora Kernel Team 2015-04-28 18:33:15 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 21 kernel bugs.

Fedora 21 has now been rebased to 3.19.5-200.fc21.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 22, and are still experiencing this issue, please change the version to Fedora 22.

If you experience different issues, please open a new bug report for those.

Comment 7 JonRam 2015-05-05 21:52:54 UTC
Still present in F22 and kernel 4.0.1-300.fc22.

Comment 8 George Moutsopoulos 2015-05-05 22:02:53 UTC
a patch has been committed. 
Input: elantech - fix absolute mode setting on some ASUS laptops
to the 4.0-stable tree which can be found at:
    http://www.kernel.org/git/?p=linux/kernel/git/stable/stable-queue.git;a=summary
Until then, I am using a patched dkms updated driver without problem. I attach my dkms 
sudo dkms add -m psmouse -v edt0108
sudo dkms build -m psmouse -v edt0108
sudo dkms install -m psmouse -v edt0108
update-initramfs
(on ubuntu)

Comment 9 George Moutsopoulos 2015-05-05 22:06:48 UTC
Created attachment 1022340 [details]
patched psmouse

copy to /usr/src and then
sudo dkms add -m psmouse -v edt0108
sudo dkms build -m psmouse -v edt0108
sudo dkms install -m psmouse -v edt0108
update-initramfs
the dkms.conf is mine so comment if you find something wrong

Comment 10 George Moutsopoulos 2015-05-05 22:08:12 UTC
Created attachment 1022341 [details]
patch for kernels 3.16-4.0

Comment 11 George Moutsopoulos 2015-05-05 22:22:59 UTC
that should have been -v etd0108

Comment 12 Fedora Update System 2015-05-08 12:18:16 UTC
kernel-4.0.2-300.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kernel-4.0.2-300.fc22

Comment 13 Fedora Update System 2015-05-11 19:03:10 UTC
kernel-4.0.2-300.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 mohican 2015-05-17 11:02:24 UTC
Hi George,
I have a similar problem on a ASUS X751LD with this touchpad id=ETD0108.

I'am trying to install your patch on a Ubuntu 14.04 fresh install (kernel 3.13).

I extracted your patch from comment 9 to /usr/src so the directory is :
/usr/src/psmouse-etd0108

then I run the commands (with etd0108) :

dkms add : this creates a symlink /var/lib/dkms/psmouse/etd0108/source -> /usr/src/psmouse-etd0108

dkms build : make returned bad exit status: 2 ERROR (dkms apport) "binary package for psmouse: etd1008 not found"

(***I'm not used to build kernel modules***)

Question 1 : can your patch work with kernel version 3.13 or do I have to upgrade the kernel ? If so should I use your updated patch from comment 10 ? If so how to download it (or apply the update to the patch in comment 9)

Question 2 : did I extract the patch in the correct folder ?

Question 3 : do I have to run the commands from a specific folder ?

Thank you.

Comment 15 George Moutsopoulos 2015-05-20 07:47:26 UTC
Hi mohican.
Q1) don't know. for me it worked with kernel > 3.16. 
Q2) yes. and inside /usr/src/psmouse-etd0108 find dkms.conf and src/
Q3) no

Suggestions 

1) try sudo su before everything. I also noted that the error
dkms build : make returned bad exit status: 2 ERROR (dkms apport) "binary package for psmouse: etd1008 not found"
would make more sense if it said
dkms build : make returned bad exit status: 2 ERROR (dkms apport) "binary package for psmouse: ****etd0108**** not found"
maybe a wrong command?
sudo dkms build -m psmouse -v etd0108

2) install sudo apt-get install build-essential linux-headers-$(uname -r) dkms just in case something is missing

3) the dkms commands are so that a new mouse module is built automatically whenever you update your kernel. Perhaps you can try to install the module *once* for the kernel you are using (and then refrain from updating your kernel). Enter the src folder and run
make -C /lib/modules/$(uname -r)/build M=$(pwd) modules
make -C /lib/modules/$(uname -r)/build M=$(pwd) modules_install
this would build it in the folder and also install it in 
/lib/modules/.../extra/psmouse.ko
you should now make sure this specific version is the one loaded. not sure how but I would remove (rename) the original psmouse.ko in /lib/modules/.../drivers/input/mouse/ and replace it with this one. To test without rebooting, rmmod -r psmouse and insmod psmouse.ko from the folder you are in. See also 
http://askubuntu.com/questions/515407/how-recipe-to-build-only-one-kernel-module
if the above in (3) do not work
Good luck!


Note You need to log in before you can comment on or make changes to this bug.