Bug 1182957 - FTBFS: cutter-1.2.4-2.fc21 on F-21 and above
Summary: FTBFS: cutter-1.2.4-2.fc21 on F-21 and above
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cutter
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kentaro Hayashi
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/clear-code/cutter/...
Whiteboard:
Depends On:
Blocks: 1197577
TreeView+ depends on / blocked
 
Reported: 2015-01-16 10:24 UTC by Mamoru TASAKA
Modified: 2015-03-19 18:42 UTC (History)
1 user (show)

Fixed In Version: cutter-1.2.4-4.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1197577 (view as bug list)
Environment:
Last Closed: 2015-03-19 18:38:41 UTC
Type: Bug


Attachments (Terms of Use)
try to fix "make check" failure patch for rawhide (523 bytes, patch)
2015-02-17 14:45 UTC, Kentaro Hayashi
no flags Details | Diff
test-suite.log on F-22 (4.92 KB, text/plain)
2015-02-20 11:03 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2015-01-16 10:24:01 UTC
Description of problem:
Currently cutter [cutter-1.2.4-2.fc21] FTBFS (Fail To Build From Source) on F-21 and above. Please fix this.

http://koji.fedoraproject.org/koji/buildinfo?buildID=555444


Additional info:
This fix is needed:
https://github.com/clear-code/cutter/issues/19

Comment 1 Kentaro Hayashi 2015-02-14 05:12:16 UTC
Thank you for reporting!

It needs one more patch to fix "make check" failure.

Here is the commit to support newer GLib error message.
https://github.com/clear-code/cutter/commit/3947d292996458f3800e93021b86e1476f85922b

By this commit, it seems well for F-21, but F-22 still have problem.
It is a bit strange because mock build is ok, but koji --scrach build fails.

Crash: test_limit_block (default context)
https://kojipkgs.fedoraproject.org//work/tasks/4273/8934273/build.log

Comment 2 Kentaro Hayashi 2015-02-14 05:59:03 UTC
(In reply to HAYASHI Kentaro from comment #1)
> It is a bit strange because mock build is ok, but koji --scrach build fails.
> 
> Crash: test_limit_block (default context)
> https://kojipkgs.fedoraproject.org//work/tasks/4273/8934273/build.log

It needs more patches which are already fixed in upstream.

Then, make check process is a bit more succeeded now.
https://kojipkgs.fedoraproject.org//work/tasks/4737/8934737/build.log

Comment 3 Kentaro Hayashi 2015-02-17 14:45:49 UTC
Created attachment 992728 [details]
try to fix "make check" failure patch for rawhide

Comment 4 Kentaro Hayashi 2015-02-17 15:20:54 UTC
(In reply to HAYASHI Kentaro from comment #3)
> Created attachment 992728 [details]
> try to fix "make check" failure patch for rawhide

F-21: it's ok without this patch
rawhide: it's ok with this patch

F-21: gcc 4.9.2-6
rawhide: gcc 5.0.0-0.13

rawhide default: faild
rawhide with --enable-debug: failed

So, there is nothing to do with optimization.

And, there is no difference compile option for test-cppcut-assertions.cpp.

Comment 5 Kentaro Hayashi 2015-02-17 16:30:49 UTC
(In reply to HAYASHI Kentaro from comment #4)
> (In reply to HAYASHI Kentaro from comment #3)
> > Created attachment 992728 [details]
> > try to fix "make check" failure patch for rawhide
> 
> F-21: it's ok without this patch
> rawhide: it's ok with this patch
> 

typo, It's ok for f-21 and f22, not rawhide.

Comment 6 Mamoru TASAKA 2015-02-20 11:03:39 UTC
Created attachment 993869 [details]
test-suite.log on F-22

By the way, I tried git head (3947d292996458f3) on F-22 (both i386,
x86_64) and make check fails like:

FAIL: run-test.sh
============================================================================
Testsuite summary for cutter 1.2.4
============================================================================
# TOTAL: 1
# PASS:  0
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See test/test-suite.log
Please report to kou@clear-code.com
============================================================================

test/test-suite.log attached. (While I have not investigated in detail) it looks like (again just my guess) this segv is derived from cutter/test-cut-test.c:323. and the signal wasn't caught properly...???

Comment 7 Mamoru TASAKA 2015-02-20 11:09:05 UTC
I reported the issue on my comment 6 to the upstream:
https://github.com/clear-code/cutter/issues/20

Comment 8 Fedora Update System 2015-02-25 14:02:51 UTC
cutter-1.2.4-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/cutter-1.2.4-4.fc22

Comment 9 Fedora Update System 2015-02-25 14:33:55 UTC
cutter-1.2.4-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/cutter-1.2.4-4.fc21

Comment 10 Kentaro Hayashi 2015-02-25 14:48:35 UTC
I've checked again build status for http://pkgs.fedoraproject.org/cgit/cutter.git/.

koji reports:
  rawhide stil fail
  f22 succeeded
  f21 succeeded

Here is the build logs:

  rawhide makecheck failed
  http://koji.fedoraproject.org/koji/taskinfo?taskID=9066948

  f22 make check succeeded
  http://koji.fedoraproject.org/koji/taskinfo?taskID=9066950

  f21 make check succeeded
  http://koji.fedoraproject.org/koji/taskinfo?taskID=9066960

The situation is different because it doesn't segv on f-22.

Comment 11 Fedora Update System 2015-02-25 15:15:30 UTC
Package cutter-1.2.4-4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cutter-1.2.4-4.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2555/cutter-1.2.4-4.fc22
then log in and leave karma (feedback).

Comment 12 Mamoru TASAKA 2015-02-26 05:35:57 UTC
Currently I have no idea the cause of test failure on F-23.

Comment 13 Jaroslav Reznik 2015-03-03 17:19:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 14 Fedora Update System 2015-03-19 18:38:41 UTC
cutter-1.2.4-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-03-19 18:42:34 UTC
cutter-1.2.4-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.