Bug 118301 - mysql_config --libs reports -L'/usr/lib/mysql' (ie, with quotes)
mysql_config --libs reports -L'/usr/lib/mysql' (ie, with quotes)
Status: CLOSED DUPLICATE of bug 129409
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-15 07:12 EST by Thomas Vander Stichele
Modified: 2013-07-02 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Vander Stichele 2004-03-15 07:12:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
I have never seen any program use quotes to pass these flags.  What's
more, testing for mysqlclient using AC_CHECK_LIB fails because of
this.  removing the quoting from mysql_config makes it work correctly
again.

I suggest the quotes be removed from mysql_config.

Version-Release number of selected component (if applicable):
mysql-3.23.58-4

How reproducible:
Always

Steps to Reproduce:
1. mysql_config --libs
2.
3.
    

Additional info:
Comment 1 Tom Lane 2004-03-15 10:30:41 EST
This behavior seems perfectly reasonable to me, and indeed necessary
in some scenarios --- consider a pathname that contains spaces.  If
AC_CHECK_LIB has a problem with it, I suggest you should file a bug
against autoconf.
Comment 2 Thomas Vander Stichele 2004-03-15 10:35:53 EST
Hm.  I have yet to see the first project do that though :)
You think it is better to start filing bugs with all upstream
pkg-config using projects to start quoting their libs ?
Comment 3 Tom Lane 2004-03-15 11:14:03 EST
mysql is probably more sensitive to the spaces-in-pathnames issue than
most projects, since they have a heavily used Windows port and spaces
in pathnames are quite common on Windows.  So you'd probably not get
much uptake on the idea from other projects.  I do not however feel a
desire to second-guess the mysql project's coding.

Out of curiosity, why do you say that this breaks AC_CHECK_LIB?  I
would not have thought that AC_CHECK_LIB knows anything at all about
mysql_config.
Comment 4 Tom Lane 2004-12-08 21:06:58 EST

*** This bug has been marked as a duplicate of 129409 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:01:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.