Bug 1183035 - VM with VDC subscription gets unentitled when it migrate
Summary: VM with VDC subscription gets unentitled when it migrate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: 6.0.6
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Michael Stead
QA Contact: Chris Roberts
URL:
Whiteboard:
Depends On:
Blocks: 1139277
TreeView+ depends on / blocked
 
Reported: 2015-01-16 14:19 UTC by David Juran
Modified: 2019-09-25 20:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:13:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description David Juran 2015-01-16 14:19:14 UTC
Description of problem:
A VM entitled with a VDC subscription gets unentitled when it migrates.

Version-Release number of selected component (if applicable):
satellite 6.0.6

Steps to Reproduce:
1. Entitle a VM with an virtual subscription tied to a specific hypervisor
2. Migrate the VM to a different hypervisor
3. Wait for virt-who to update the mappings
4. Note how the VM gets unentitled.

Additional info:
It's been suggested that the problem can be worked around by setting autoAttachInterval equal to certCheckInterval in /etc/rhsm/rhsm.conf

The VM will still show up red in the satellite but updates will hopefully not fail.

Comment 2 Devan Goodwin 2015-01-23 18:09:25 UTC
An implicit auto-heal when migration is detected is currently underway as part of the larger effort to improve virt-who performance. Assigning to the developer looking into this at the moment.

Comment 3 Devan Goodwin 2015-03-18 12:14:45 UTC
An autoheal is now done when we detect guest migration and revoke entitlements. Fixed in candlepin builds somewhere around 0.9.47 and shipping in Sat 6.1.

Comment 7 errata-xmlrpc 2016-07-27 09:13:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.