Bug 1183056 - Signature extraction failed
Summary: Signature extraction failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-16 15:16 UTC by Peter H. Jones
Modified: 2015-02-07 03:57 UTC (History)
4 users (show)

Fixed In Version: youtube-dl-2015.01.25-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-01 00:24:30 UTC
Type: Bug


Attachments (Terms of Use)
typescript file (5.18 KB, text/plain)
2015-01-16 15:16 UTC, Peter H. Jones
no flags Details
script output (3.77 KB, text/plain)
2015-01-28 22:48 UTC, Peter H. Jones
no flags Details
script output (3.77 KB, text/plain)
2015-01-28 22:51 UTC, Peter H. Jones
no flags Details

Description Peter H. Jones 2015-01-16 15:16:16 UTC
Created attachment 980859 [details]
typescript file

Description of problem:
Can't download an audio-only file

Version-Release number of selected component (if applicable):
youtube-dl-2014.12.10.3-1.fc20.noarch

How reproducible:
Every time.

Steps to Reproduce:
1. youtube-dl --verbose 'https://www.youtube.com/watch?v=z-eiZ-sGzCU'

Actual results:
Backtrace, see attached typescript

Expected results:
Downloading audio file

Comment 1 Till Maas 2015-01-28 19:50:56 UTC
I cannot reproduce this, because the video is copyright protected and not available here. Please test it with a current version https://admin.fedoraproject.org/updates/youtube-dl-2015.01.25-1.fc21

if it is not fixed, please provide a differen youtube URL that can be freely accessed so I can test it or report it upstream.

Comment 2 Peter H. Jones 2015-01-28 22:48:20 UTC
Created attachment 985403 [details]
script output

Works fine, even on an FC20 system. Hope this version can be backported.

Comment 3 Peter H. Jones 2015-01-28 22:51:44 UTC
Created attachment 985406 [details]
script output

Works fine, even on an FC20 system.

Comment 4 Fedora Update System 2015-01-28 22:59:48 UTC
youtube-dl-2015.01.25-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/youtube-dl-2015.01.25-1.fc20

Comment 5 Fedora Update System 2015-01-28 22:59:54 UTC
youtube-dl-2015.01.25-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/youtube-dl-2015.01.25-1.fc21

Comment 6 Fedora Update System 2015-01-28 23:01:00 UTC
youtube-dl-2015.01.25-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/youtube-dl-2015.01.25-1.fc20

Comment 7 Peter H. Jones 2015-01-29 07:30:19 UTC
youtube-dl-2015.01.25-1.fc20.noarch worked for the URL given in the description.

Comment 8 Fedora Update System 2015-01-30 04:34:04 UTC
Package youtube-dl-2015.01.25-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing youtube-dl-2015.01.25-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1344/youtube-dl-2015.01.25-1.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-02-01 00:24:30 UTC
youtube-dl-2015.01.25-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-02-07 03:57:10 UTC
youtube-dl-2015.01.25-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.