Bug 118315 - system-install-packages displays "Your account does not have permissions to run system-install-packages." dialog
Summary: system-install-packages displays "Your account does not have permissions to r...
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-15 15:38 UTC by Garrett LeSage
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-13 19:59:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Garrett LeSage 2004-03-15 15:38:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040225 Firefox/0.6.1 StumbleUpon/1.79

Description of problem:
system-install-packages displays "Your account does not have
permissions to run system-install-packages." instead of installing
packages.

Version-Release number of selected component (if applicable):
system-config-packages-1.9.3-2

How reproducible:
Always

Steps to Reproduce:
1. run "system-install-packages" with an RPM specified


Actual Results:  The following text is displayed in a dialog

"Your account does not have permissions to run system-install-packages.

Administrator level permissions are needed to run this program because
it can install and remove system packages."

Expected Results:  A dialog to install packages should show up.

Additional info:

Comment 1 Jeremy Katz 2004-03-15 17:18:03 UTC
Are you running as root?

Comment 2 Garrett LeSage 2004-03-15 17:23:09 UTC
No, running as a user.  Shouldn't it pop up a dialog to ask for the password?

Comment 3 Jeremy Katz 2004-03-15 19:01:25 UTC
It depends... if you have /usr/sbin in your path first, then it won't
due to the way userhelper works.


Note You need to log in before you can comment on or make changes to this bug.