Bug 1183260 - crash
Summary: crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: extremetuxracer
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1046966 1133626 1173921 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-17 20:52 UTC by Stas Sergeev
Modified: 2015-05-28 12:06 UTC (History)
3 users (show)

Fixed In Version: extremetuxracer-0.6.0-7.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-26 03:36:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Stas Sergeev 2015-01-17 20:52:39 UTC
Description of problem:
Tuxracer crashes at "Who Says Penguins Can't Fly?" map.

Version-Release number of selected component (if applicable):
extremetuxracer-0.6.0-6.fc21.x86_64

How reproducible:
easily

Steps to Reproduce:
1. enter the specified map

Actual results:
crash

Expected results:
no crash

Additional info:
There is already a bug report for ubuntu:
https://bugs.launchpad.net/etracer/+bug/1332986
and the patch:
https://launchpadlibrarian.net/178438888/etr-sigsegv.patch

Comment 1 Nils Philippsen 2015-02-11 12:14:44 UTC
Thanks, I've applied a modified version of the linked patch to the package git repo:

commit 410edad6090b50744f3f158ae2e8a4b7178546b9
Author:     Nils Philippsen <nils@redhat.com>
AuthorDate: Wed Feb 11 13:12:55 2015 +0100
Commit:     Nils Philippsen <nils@redhat.com>
CommitDate: Wed Feb 11 13:12:55 2015 +0100

    don't crash in treeless levels
    
    (#1183260, thanks to Jakub Vaněk for the original patch)

Comment 2 Nils Philippsen 2015-02-11 12:15:57 UTC
*** Bug 1173921 has been marked as a duplicate of this bug. ***

Comment 3 Nils Philippsen 2015-02-11 12:16:37 UTC
*** Bug 1046966 has been marked as a duplicate of this bug. ***

Comment 4 Nils Philippsen 2015-02-11 12:16:50 UTC
*** Bug 1133626 has been marked as a duplicate of this bug. ***

Comment 5 Nils Philippsen 2015-05-12 15:21:43 UTC
Ugh, dropped the ball on this. Packages with the fix are building right now.

Comment 6 Fedora Update System 2015-05-12 15:33:51 UTC
extremetuxracer-0.6.0-7.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/extremetuxracer-0.6.0-7.fc22

Comment 7 Fedora Update System 2015-05-12 15:33:57 UTC
extremetuxracer-0.6.0-7.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/extremetuxracer-0.6.0-7.fc21

Comment 8 Fedora Update System 2015-05-12 15:34:04 UTC
extremetuxracer-0.6.0-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/extremetuxracer-0.6.0-7.fc20

Comment 9 Fedora Update System 2015-05-13 08:20:39 UTC
Package extremetuxracer-0.6.0-7.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing extremetuxracer-0.6.0-7.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8103/extremetuxracer-0.6.0-7.fc22
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-05-26 03:36:42 UTC
extremetuxracer-0.6.0-7.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-05-28 12:03:07 UTC
extremetuxracer-0.6.0-7.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-05-28 12:06:07 UTC
extremetuxracer-0.6.0-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.