Bug 118328 - mii-tool/ethtool doesnt work with 2.6 kernel.
mii-tool/ethtool doesnt work with 2.6 kernel.
Status: CLOSED DUPLICATE of bug 119965
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-15 11:46 EST by Dams
Modified: 2013-07-02 22:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2004-03-15 11:46:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1)
Gecko/20031114 Galeon/1.3.13

Description of problem:
mii-tool and ethtool always worked fine with 2.4 kernel on FC1 (and
before, with old hat linux rh9/rh8/etc...). But mii-tool and ethtool
never worked so far with 2.6 kernel (my first 2.6 kernel was a
2.6.0-testX from arjan repository on people.r.c).

[root@gruyere ~]# ethtool eth0
Settings for eth0:
No data available
zsh: exit 75    ethtool eth0
[root@gruyere ~]# mii-tool
eth0: 10 Mbit, half duplex, no link


Here is the lspci -vvv describing the NIC : 
02:06.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado]
(rev 30)
  Subsystem: 3Com Corporation 3C905C-TX Fast Etherlink for PC
Management NIC
  Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr-
Stepping- SERR- FastB2B-
  Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
  Latency: 32 (2500ns min, 2500ns max), cache line size 08
  Interrupt: pin A routed to IRQ 177
  Region 0: I/O ports at a800 [size=128]
  Region 1: Memory at ee800000 (32-bit, non-prefetchable) [size=128]
  Expansion ROM at <unassigned> [disabled] [size=128K]
  Capabilities: [dc] Power Management version 2
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold+)
      Status: D0 PME-Enable- DSel=0 DScale=2 PME-

The driver is, of course, 3c59x kernel module.

It's annoying because network scripts wont launch dhclient if
ethtool/mii-tool say there is 'no link'. Once i patched network
scripts to ignore this, the NIC, driver, and network scripts worked
perfectly.

Version-Release number of selected component (if applicable):
2.6.3-1.118smp

How reproducible: Always. With all 2.6 kernels i've tested so far.
Comment 1 Seth Vidal 2004-04-05 12:50:26 EDT

*** This bug has been marked as a duplicate of 119965 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.