Bug 1183293 - Change rpc-statd-notify.service to not wait for network-online.target
Summary: Change rpc-statd-notify.service to not wait for network-online.target
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: 21
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-18 07:38 UTC by Eric Work
Modified: 2015-03-31 21:38 UTC (History)
5 users (show)

Fixed In Version: nfs-utils-1.3.1-6.2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-29 04:24:17 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1195998 unspecified CLOSED ldconfig.service runs on live boot, slowing down the boot substantially 2020-10-14 00:28:05 UTC

Internal Links: 1195998

Description Eric Work 2015-01-18 07:38:31 UTC
Description of problem:

Currently rpc-statd-notify.service requires network-online.target.  This means that installing nfs-utils, which enables nfs-client.target, which depends on rpc-statd-notify.service, results in you waiting for the network to come online.  You may have installed nfs-utils just to mount something one time or for autofs such as myself.  Because of the forking change made to the rpc-statd-notify.service service I think we can make this depend on network.target instead.  It should wait in the background for up to 15 min to try and notify servers.  This saved 10 seconds off my boot by simply changing this dependency.  There could of course be a flaw in my logic :-)

Version-Release number of selected component (if applicable):

nfs-utils-1.3.1-5.0.fc21

Additional info:

Since bug 1181708 has been fixed this should now be possible I think.

Comment 1 Eric Work 2015-01-31 20:42:10 UTC
Any comment on this idea?  Does it sound like a good solution or not?

Comment 2 Steve Dickson 2015-02-04 13:45:40 UTC
(In reply to Eric Work from comment #1)
> Any comment on this idea?  Does it sound like a good solution or not?

I did take a look at this... it seems in network-online.target there
is an After=network.target which mean network.target will be
started first so I still think there will be a delay... 

have you tested it out?

Comment 3 Eric Work 2015-02-04 20:28:10 UTC
From my observations network.target only requires that the interfaces are up as opposed to connected to the network with an IP with network-online.target.  In my case I don't have any NFS notifications to be sent so I can't say what would happen with just network.target if that was the case.  My assumption was that it would try to 15 minutes which by then the interface should have an IP.  Making this change does save a lot of time on my system which boots pretty quick due to a BIOS with a fast boot mode and SSDs.

Comment 4 Fedora Update System 2015-02-09 19:23:14 UTC
nfs-utils-1.3.1-6.1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/nfs-utils-1.3.1-6.1.fc21

Comment 5 Eric Work 2015-02-10 08:30:21 UTC
Steve,

It looks like both "Requires" and "After" need to be changed to "network.target" in order to get the benefit.  I have the following lines locally.

Requires=network.target
After=network.target nss-lookup.target

This cuts my boot time from the big red button push to 21 sec instead of the original 31 sec because the login prompt is not waiting for the internet to come up.  Only changing "After" didn't have any effect unfortunately.

Comment 6 Fedora Update System 2015-02-15 03:23:00 UTC
nfs-utils-1.3.1-6.1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Eric Work 2015-03-03 19:36:04 UTC
Awesome!

Comment 9 Wolfgang Ulbrich 2015-03-08 18:49:43 UTC
Can you please push new release to f22 at bodhi ?
See, https://bugzilla.redhat.com/show_bug.cgi?id=1195998#c14

Comment 10 Fedora Update System 2015-03-20 15:52:56 UTC
nfs-utils-1.3.1-6.2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/nfs-utils-1.3.1-6.2.fc21

Comment 11 Fedora Update System 2015-03-22 04:33:52 UTC
Package nfs-utils-1.3.1-6.2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nfs-utils-1.3.1-6.2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4391/nfs-utils-1.3.1-6.2.fc21
then log in and leave karma (feedback).

Comment 12 Wolfgang Ulbrich 2015-03-22 17:01:20 UTC
Is there a reason why you don't push any update to f22 at bodhi?
Sorry, i have removed nfs-utils from mate livecd spin to avoid a slow boot, until you update f22.

Comment 13 Steve Dickson 2015-03-22 17:18:02 UTC
(In reply to Wolfgang Ulbrich from comment #12)
> Is there a reason why you don't push any update to f22 at bodhi?
> Sorry, i have removed nfs-utils from mate livecd spin to avoid a slow boot,
> until you update f22.

Sorry.. at this point I didn't think I needed to... Will do!

Comment 14 Fedora Update System 2015-03-22 17:23:27 UTC
nfs-utils-1.3.2-2.0.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/nfs-utils-1.3.2-2.0.fc22

Comment 15 Wolfgang Ulbrich 2015-03-22 17:49:03 UTC
Thanks,
the issue still exists with nfs-utils-1.3.2-0.2.fc22 from f22 stable, tested with a local build livecd, today.

Comment 16 Wolfgang Ulbrich 2015-03-22 19:13:15 UTC
Confirmed that nfs-utils-1.3.2-2.0.fc22 fix the issue with mate-compiz live spin.
NetworkManager-wait-online.service doesn't start anymore.

Comment 17 Fedora Update System 2015-03-29 04:24:17 UTC
nfs-utils-1.3.2-2.0.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2015-03-31 21:38:00 UTC
nfs-utils-1.3.1-6.2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.