Bug 1183307 - [RFE][HC] - a more integrated workflow is needed when removing a storage domain in hyperconverged cluster
Summary: [RFE][HC] - a more integrated workflow is needed when removing a storage doma...
Keywords:
Status: CLOSED DUPLICATE of bug 1182784
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: Liron Aravot
QA Contact: Aharon Canan
URL:
Whiteboard:
Depends On: 1182774 1183306 1620198
Blocks: Generic_Hyper_Converged_Host 1182784 Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2015-01-18 12:57 UTC by Yaniv Lavi
Modified: 2019-04-28 09:17 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1182784
Environment:
Last Closed: 2016-03-08 13:25:41 UTC
oVirt Team: Gluster
ylavi: ovirt-4.0.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

Description Yaniv Lavi 2015-01-18 12:57:58 UTC
+++ This bug was initially created as a clone of Bug #1182784 +++

Description of problem:
The virt admin will manage the environment based on high level virt objects in the UI first - i.e. a storage domain. When releasing a storage domain, the workflow is not 'linked' between handling the removal of the oVirt object and the glusterfs volume.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Removing a storage domain in a hyperconverged use case should have a workflow similar to the following;

1. admin moves SD to maintenance
2. With the Sd detached, the admin opens the storage tab, selects the domain to remove and chooses "destroy"
3. if the SD was glusterfs domain the "Destroy storage domain" modal dialog should include an option to stop and delete the underlying glusterfs volume
4. if the option to remove the gluster volume is checked a further check box to purge any data from the volume should be provided


Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 11:01:26 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Sahina Bose 2016-03-08 12:55:11 UTC
Isn't this a duplicate of Bug 1182784?

Comment 3 Yaniv Lavi 2016-03-08 13:25:41 UTC
Y(In reply to Sahina Bose from comment #2)
> Isn't this a duplicate of Bug 1182784?

Yes

*** This bug has been marked as a duplicate of bug 1182784 ***


Note You need to log in before you can comment on or make changes to this bug.