Bug 1183412 - Emails to administrators are sent in the current interface language.
Summary: Emails to administrators are sent in the current interface language.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Usability   
(Show other bugs)
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.6
Assignee: Sean Flanigan
QA Contact: Damian Jansen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: Zanata-3.6.1
TreeView+ depends on / blocked
 
Reported: 2015-01-19 01:08 UTC by David Mason
Modified: 2015-04-20 01:26 UTC (History)
3 users (show)

Fixed In Version: 3.6.1-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-3082)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-20 01:26:56 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Mason 2015-01-19 01:08:53 UTC
Description of problem:
When a user sends an email to the administrator, the template text of the email uses the language setting of the Zanata interface of the signed-in user. Emails to administrators should be in the administrator's language. There is no way at the moment to set the language for the administrator emails. 


How reproducible:
Easy, always.

Steps to Reproduce:
1.Sign in with any account and change the interface language
2.Use the 'email administrator' feature to send an email with any content.
3.Find the email in the administrator inbox.

Actual results:
Text is in the language that the interface was changed to in step 1

Expected results:
Emails to administrators are sent in the default language, which is English at the moment. It would also be handy of the default admin language for a server could be changed.

Additional info:
Note that when an internal message system is implemented, admin users may be able to choose their preferred email language.

Comment 1 Sean Flanigan 2015-03-09 05:38:26 UTC
This is becoming a bigger problem as Zanata is translated into more languages.

Comment 2 Sean Flanigan 2015-03-20 01:18:01 UTC
Note to self:  

Looks like these classes are involved in this behaviour:

org.zanata.email.EmailBuilder
org.zanata.i18n.Messages
org.jboss.seam.core.Locale

Comment 3 Sean Flanigan 2015-03-23 01:13:32 UTC
Pull request: https://github.com/zanata/zanata-server/pull/740

Comment 4 Damian Jansen 2015-03-24 03:09:25 UTC
Verified (release) at 600d7882e7e666bdec3e62537d3c3541225fb611
Verified (master) at fe9939daf11fdd3feb2302e241cda4aab85de8cd


Note You need to log in before you can comment on or make changes to this bug.