Bug 1183501 - [GSS](6.4.z) JBoss init scripts time out when using full profiles (zip)
Summary: [GSS](6.4.z) JBoss init scripts time out when using full profiles (zip)
Status: CLOSED WORKSFORME
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Scripts and Commands
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Radovan STANCEL
QA Contact: Marek Kopecky
URL:
Whiteboard:
Keywords:
Depends On: 960741
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-19 08:40 UTC by Petr Kremensky
Modified: 2018-12-01 15:12 UTC (History)
7 users (show)

(edit)
Clone Of: 960741
(edit)
Last Closed: 2016-09-27 13:30:24 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 960741 None None None Never
Red Hat Bugzilla 1224170 None None None Never

Internal Trackers: 960741 1224170

Description Petr Kremensky 2015-01-19 08:40:43 UTC
+++ This bug was initially created as a clone of Bug #960741 +++

Description of problem:
Users will experience a timeout bug when starting their server in standalone-full-ha profile.

jboss-as-standalone.sh snippet
...
  until [ $count -gt $STARTUP_WAIT ]
  do
    grep 'JBAS015874:' $JBOSS_CONSOLE_LOG > /dev/null
    if [ $? -eq 0 ] ; then
      launched=true
      break
    fi
    sleep 1
    let count=$count+1;
  done
...


Version-Release number of selected component (if applicable):
 EAP 6.4.0.ER1

How reproducible:
 Always

Steps to Reproduce:
 1. Add the following line into $JBOSS_HOME/bin/init.d/jboss-as.conf file
JBOSS_CONFIG=standalone-full-ha.xml
 2. follow the documentation to start standalone server as a service http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html/Installation_Guide/Install_JBoss_Enterprise_Application_Platform_6_Red_Hat_Enterprise_Linux_Service.html


Actual results:
Starting jboss-as: jboss-as failed to startup in the time allotted
                                                           [FAILED]

Expected results:
Starting jboss-as:                                         [  OK  ]

Comment 2 Peter Palaga 2016-07-04 09:44:00 UTC
Agreed with Tomaž to assign to jboss-set@redhat.com

Comment 3 Radovan STANCEL 2016-09-27 13:30:24 UTC
I am not able to reproduce it with 6.4.10 version. This issue has been fixed with other issues (see 960741).


Note You need to log in before you can comment on or make changes to this bug.