Bug 118351 - can't save buttons inside a toolbar
Summary: can't save buttons inside a toolbar
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-15 20:53 UTC by Brent Fox
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 20:36:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brent Fox 2004-03-15 20:53:25 UTC
Steps to reproduce:

1. Create a new Glade project
2. Create a GtkWindow
3. Put a GtkToolbar inside the window
4. Put some GtkButtons inside the toolbar
5. Save the project somewhere.

Now open the glade file in a text editor and look for the GtkButtons.
 They aren't getting written to the glade file.  

I'm seeing this with glade2-2.0.0-2 from FC1 as well as glade2-2.0.1-1
in Rawhide.

Comment 1 Brent Fox 2004-03-24 18:00:04 UTC
Actually, I'm seeing this as far back as glade-1.1.3-3 from RHL 9. 
I'm guessing that the problem lies with libglade2 since I know that
glade2 from RHL 9 worked.

Comment 2 Brent Fox 2004-03-24 19:25:09 UTC
I installed a fresh FC1 system and then started upgrading individual
packages until I saw the behavior.  Turns out the bug is triggered
when bonobo-1.0.22-8.1 is installed.  

Comment 3 Brent Fox 2004-03-24 19:51:21 UTC
Doh, sorry.  Scratch that last post.  The problem occurs after I
upgraded to gtk2-2.4.0-1 and gtk2-devel-2.4.0-1.

Comment 4 Matthias Clasen 2004-05-12 20:36:14 UTC
This works fine for me with the glade2-2.5.0-1 in FC2


Note You need to log in before you can comment on or make changes to this bug.