Bug 118352 - (VM) setfiles exhausts available memory
(VM) setfiles exhausts available memory
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC2Target FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-03-15 16:03 EST by Dan Williams
Modified: 2015-01-04 17:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 13:23:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel messages when running out of memory running setfiles (106.53 KB, text/plain)
2004-03-17 11:29 EST, Dan Williams
no flags Details

  None (edit)
Description Dan Williams 2004-03-15 16:03:56 EST
Description of problem:
When running 'make relabel' on a drive with large numbers of files
(150000) setfiles eventually consumes all available memory and begins
to swap.  It eventually uses all swap and hangs machine

Version-Release number of selected component (if applicable):
policycoreutils-1.6-8

How reproducible:
every time on my x86_64 box

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2004-03-17 10:35:30 EST
This looks like it might be a kernel problem.

The app is not growing but free memory is dropping.

> Stephen Smalley says he sees similar behaviour when running
> Ah, good point - I was just looking at memory consumption by the
> process, not at the massive bleeding of overall free memory during a
> setfiles run.  Looks like find / -xdev -ls > /dev/null yields the 
> same result; requires further investigation.

Memory seems to free up when the app exits.


Comment 2 Dan Williams 2004-03-17 11:29:30 EST
Created attachment 98608 [details]
kernel messages when running out of memory running setfiles

This is using kernel 2.6.3-2.1.253 on x86-64 box
Comment 3 James Morris 2004-04-08 12:26:08 EDT
I've looked into this on i386 and have not observed anything unusual
(e.g. memory pressure reclaims dcache, ext3 inode cache slab entries
just fine).

Can you please test with the current Fedora kernel?

If you still see the problem, are you able to duplicate it on an i386 box?
Comment 4 Alan Cox 2004-05-03 12:35:02 EDT
This looks a lot like the updatedb problem report. You might want to
try Arjan's latest and greatest
Comment 5 Dave Jones 2004-12-07 01:15:55 EST
still a problem with the 2.6.9 updates ?
Comment 6 Dan Williams 2004-12-09 13:23:30 EST
Haven't experienced for some time, if it occurs again I'll reopen or
file a new one.

Note You need to log in before you can comment on or make changes to this bug.