This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 118368 - Qt clipboard causes crash
Qt clipboard causes crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-15 18:47 EST by A tech
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-23 10:57:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fixes drag and drop crash in Qt 3.2.x to 3.3.1 (2.68 KB, patch)
2004-03-15 18:52 EST, A tech
no flags Details | Diff

  None (edit)
Description A tech 2004-03-15 18:47:39 EST
Description of problem: drag and drop crash caused by improper
handling of x-clipboard by Qt3


Version-Release number of selected component (if applicable):
Qt 3.2.x to 3.3.1-0.2


How reproducible:
Always


Steps to Reproduce:
1. Use Scribus 1.1.5 from fedora.us stable
2. Create new file
3. Drag any supported image format (EPS,PDF, PNG, TIF) to the page Canvas.
  
Actual results:
Consistent crash with error in console: 

QClipboard: internal error, qt_xclb_wait_for_event recursed

Expected results:
Image Should drop on to the page and be linked to image file.

Additional info:
 Fixed in latest SuSE 3.3.1-2 RPMs - see patch
Comment 1 A tech 2004-03-15 18:52:48 EST
Created attachment 98555 [details]
fixes drag and drop crash in Qt 3.2.x to 3.3.1
Comment 2 Ngo Than 2004-03-23 10:57:38 EST
it's fixed in 3.3.1-0.6. thanks for your reports

Note You need to log in before you can comment on or make changes to this bug.