Bug 118390 - Search should filter out Index items for categories
Search should filter out Index items for categories
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
nightly
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-16 05:30 EST by Arturo Dell
Modified: 2010-09-03 10:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-03 10:32:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arturo Dell 2004-03-16 05:30:43 EST
Description of problem: Index items (items that are categorised as
index for a determined category) are appearing on search results. This
doesn't make sense as these items are created specifically as a bit of
introductory text for the category in navigation. Once assigned as
index items they disappear from the itemList for example. 


Version-Release number of selected component (if applicable):


How reproducible:always


Steps to Reproduce:
1. try searching 'business' on Camden's staging server
2. result number 11 is:
http://194.202.210.43:9005/redirect/?oid=%5Bcom.arsdigita.cms.contenttypes.Article%3A%7Bid%3D37487%7D%5D

3.This is an index item
Comment 1 Daniel Berrange 2004-03-16 05:39:38 EST
It is not possible to remove the items from the search index, because
at the time the search index is populated, there is no knowledge about
whether the item is an index or not.

What might be possible, however, is to change the URL for the item so
that it instead links to the category navigation page to which it is
assigned instead of the actual item.
Comment 2 Arturo Dell 2004-03-16 05:56:58 EST
That sounds like a good temporary solution, although it would be nice 
to be able to delete items from the search index once assigned as 
category index
Comment 3 Mike Bonnet 2004-04-22 19:42:49 EDT
Committed fix (redirect to the Category URL instead of the item URL)
at p4 change 42289.
Comment 4 David Lawrence 2006-07-17 23:46:29 EDT
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.