Same problem as in bug 1131006 encountered with httpd24-httpd-2.4.6-25.el7.x86_64. With httpd24 collection installed inside a Docker container and scl-enabled, the following errors popped up:
# /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 172.17.0.5. Set the 'ServerName' directive globally to suppress this message
^C*** Error in `/opt/rh/httpd24/root/usr/sbin/httpd': free(): invalid pointer: 0x00007fd8381c7ae0 ***
*** Error in `/opt/rh/httpd24/root/usr/sbin/httpd': free(): invalid pointer: 0x00007fd8381c7ae0 ***
*** Error in `/opt/rh/httpd24/root/usr/sbin/httpd': malloc(): memory corruption: 0x00007fd834eac7c7 ***
*** Error in `/opt/rh/httpd24/root/usr/sbin/httpd': malloc(): memory corruption: 0x00007fd834eac7c7 ***
+++ This bug was initially created as a clone of Bug #1131006 +++
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://rhn.redhat.com/errata/RHBA-2015-1056.html