Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1184034

Summary: Error in `/usr/sbin/httpd': free(): invalid pointer
Product: Red Hat Software Collections Reporter: Martin Frodl <mfrodl>
Component: httpdAssignee: Jan Kaluža <jkaluza>
Status: CLOSED ERRATA QA Contact: Ondřej Pták <optak>
Severity: medium Docs Contact:
Priority: unspecified    
Version: httpd24CC: extras-qa, isenfeld, jeder, jkaluza, jorton, kanderso, mfrodl, optak, pahan, zbyszek
Target Milestone: rc   
Target Release: 2.0   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: httpd24-httpd-2.4.12-1.el7 httpd24-httpd-2.4.12-1.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1131006 Environment:
Last Closed: 2015-06-04 09:13:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 958934, 1131006    
Bug Blocks:    

Description Martin Frodl 2015-01-20 13:49:57 UTC
Same problem as in bug 1131006 encountered with httpd24-httpd-2.4.6-25.el7.x86_64. With httpd24 collection installed inside a Docker container and scl-enabled, the following errors popped up:

# /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 172.17.0.5. Set the 'ServerName' directive globally to suppress this message
^C*** Error in `/opt/rh/httpd24/root/usr/sbin/httpd': free(): invalid pointer: 0x00007fd8381c7ae0 ***
*** Error in `/opt/rh/httpd24/root/usr/sbin/httpd': free(): invalid pointer: 0x00007fd8381c7ae0 ***
*** Error in `/opt/rh/httpd24/root/usr/sbin/httpd': malloc(): memory corruption: 0x00007fd834eac7c7 ***
*** Error in `/opt/rh/httpd24/root/usr/sbin/httpd': malloc(): memory corruption: 0x00007fd834eac7c7 ***


+++ This bug was initially created as a clone of Bug #1131006 +++

Comment 4 Ondřej Pták 2015-04-15 15:29:13 UTC
httpd24-httpd-2.4.6-25.el7
==========================
:: [   PASS   ] :: Running reproducer (Expected 0, got 0)
:: [   FAIL   ] :: File '/var/tmp/tmp.T5xltWCip4' should not contain 'invalid pointer' 

httpd24-httpd-2.4.12-6.el7
==========================
:: [   PASS   ] :: Running reproducer (Expected 0, got 0)
:: [   PASS   ] :: File '/var/tmp/tmp.zh9PZto6qc' should not contain 'invalid pointer'

Comment 6 errata-xmlrpc 2015-06-04 09:13:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1056.html