Bug 118406 - (IDE IDESCSI) ide-scsi kernel module still missing
(IDE IDESCSI) ide-scsi kernel module still missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-16 08:53 EST by Tim Niemueller
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 01:05:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Niemueller 2004-03-16 08:53:20 EST
Description of problem:
The module ide-scsi is not included in the 2.6.x kernel packages. IDE
SCSI is considered to be deprecated but it is needed to get several
CD- and especially DVD-burners running (namely the NEC 1300A in my case).

Version-Release number of selected component (if applicable):
kernel 2.6.x

How reproducible:
Always

Steps to Reproduce:
1. rpm -q kernel | grep ide-scsi
  
Actual results:
Nothing

Expected results:
ide-scsi output

Additional info:
none
Comment 1 Arjan van de Ven 2004-03-20 04:41:02 EST
ide-scsi most certainly shouldn't be needed for CD burners. At all.
Can you give more specifics about why you think it's needed for your
burner anyway ?
Comment 2 Tim Niemueller 2004-03-20 16:56:12 EST
I know, that it should not be needed any more... I use X-CD-Roast for
burning DVDs at the moment (have not yet found an alternative with
comparable feature set) and this (in combination with cdrecord.ProDVD)
will not find my NEC 1300A. Only with older kernels (the ones that you
build before FC2 testing) that include the ide-scsi module I can get
this to work. If there is some app for DVD burning in FC2 that I
didn't see please let me know and I will try it out.
Comment 3 Arjan van de Ven 2004-03-23 03:40:32 EST
All you need is cdrecord --dev=/dev/hdc  (or whatever your burner is) now.
Comment 4 Warren Togami 2004-04-18 23:37:31 EDT
Tim, cdrecord does not work with Arjan's suggestion in comment #3?
Comment 5 Tim Niemueller 2004-04-20 13:19:18 EDT
No, this does not help: I'm using ProDVD at the moment to burn DVDs.
As it seems it does only search for SCSI burners. For example if you
follow the instructions in
http://fedoranews.org/tchung/xcdroast/06.shtml it won't find any drivers:

wintermute:[~]# cdrecord -scanbus
Cdrecord-Clone 2.01a25 (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot
open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

I have executed this as root to prevent any permission problems.
Kernel used was

wintermute:[~]# uname -a
Linux wintermute.niemueller.de 2.6.3-1.100 #1 Mon Feb 23 19:10:59 EST
2004 i686 i686 i386 GNU/Linux

So since the drive does not show up I cannot tell prodvd to use this
drive. Unfortunately prodvd is not open to have a look at it, but
right now this is the easiest solution I found for Gnome. Will give
K3b a try, soon. As an immediate solution the addition of the IDE-SCSI
module would fix that problem.
Comment 6 Dave Jones 2005-02-24 01:05:07 EST
I'd suggest taking this up with the prodvd author, as its clearly broken if it
forces you to use the old interface. 

Note You need to log in before you can comment on or make changes to this bug.