Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1184124 - TypeError on qpid.auto_delete_timeout assertion
Summary: TypeError on qpid.auto_delete_timeout assertion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: 3.1
: ---
Assignee: Gordon Sim
QA Contact: Petr Matousek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-20 15:37 UTC by Petr Matousek
Modified: 2015-04-14 13:48 UTC (History)
5 users (show)

Fixed In Version: qpid-cpp-0.30-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:48:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-6329 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Description Petr Matousek 2015-01-20 15:37:43 UTC
Description of problem:

There is a TypeError, when assertion on qpid.auto_delete_timeout is done:

Option qpid.auto_delete_timeout does not match for test_durable_subscription_timed_autodel-30, expected F8:int64(30), got F4:int32(30)

Version-Release number of selected component (if applicable):
qpid-cpp-*-0.30-5

How reproducible:
100%

Steps to Reproduce:
1. create a subscription with auto_delete_timeout defined in the link
# ./drain "amq.direct;{link: {name: test_durable_subscription_timed_autodel-30, timeout: 30}}" -f &
2. assert the subscription queue for qpid.auto_delete_timeout
# ./spout "test_durable_subscription_timed_autodel-30;{assert: always, node: {x-declare: {arguments: {qpid.auto_delete_timeout: 30}}}}"
3. TypeError
Option qpid.auto_delete_timeout does not match for test_durable_subscription_timed_autodel-30, expected F8:int64(30), got F4:int32(30)

Actual results:
TypeError on qpid.auto_delete_timeout assertion

Expected results:
No TypeError on qpid.auto_delete_timeout assertion

Additional info:

Comment 1 Gordon Sim 2015-01-21 14:52:43 UTC
Fixed upstream: https://svn.apache.org/r1653548

Comment 4 Petr Matousek 2015-03-12 16:18:36 UTC
This issue has been fixed. qpid.auto_delete_timeout assertion works as expected.
Verified on rhel6.6 (i686, x86_64) and rhel7.1 (x86_64).

Packages:
qpid-cpp-*-0.30-7

-> VERIFIED

Comment 6 errata-xmlrpc 2015-04-14 13:48:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.