Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 11842 - xbl doesn't work with XFree86 4.0 ATI server
xbl doesn't work with XFree86 4.0 ATI server
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: xbl (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-01 22:51 EDT by Jonathan Kamens
Modified: 2016-11-21 12:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-02 07:51:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my XF86Config file (12.75 KB, text/plain)
2000-06-02 07:51 EDT, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2000-06-01 22:51:59 EDT
When I run xbl I get:

Can't make single buffering because :
   Your display hasn't 16 colors
   OR Colors cannot be changed

I have XFree86-4.0-0.8 installed.  I will attach my XF86Config file.
Comment 1 SB 2000-06-01 23:56:25 EDT
You need to tinker with your buffering options. xbl -buffer 0 should work for 
you.  Arghh...xbl is setgid root? Crap I should make a bug report...

-Stan Bubrouski
Comment 2 Jonathan Kamens 2000-06-02 07:50:55 EDT
xbl should figure out buffering and such automatically.  I shouldn't have to
specify special command-line options to get it to work when it's capable of
working with my X server.

Furthermore, the error message is completely opaque and could use much
improvement.  I don't even understand what it's complaining about.  What does it
mean, "Your display hasn't 16 colors"?  Of course it has 16 colors.
Comment 3 Jonathan Kamens 2000-06-02 07:51:17 EDT
Created attachment 279 [details]
my XF86Config file
Comment 4 Ngo Than 2000-06-02 08:22:04 EDT
i have fixed this problem. set buffer 2. it
will work for all DISPLAY.
Comment 5 openshift-github-bot 2016-11-21 12:44:27 EST
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/826c379939d31477a4359cc4587ab55664cdbe5c
Merge pull request #11896 from jim-minter/issue11842

Merged by openshift-bot

Note You need to log in before you can comment on or make changes to this bug.