Bug 118431 - Dependancies on XFree86-xfs should not be present
Dependancies on XFree86-xfs should not be present
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-ja (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks: xorgdeps
  Show dependency treegraph
 
Reported: 2004-03-16 13:18 EST by Mike A. Harris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 8.0-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-16 23:29:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2004-03-16 13:18:13 EST
There are hard coded dependancies on XFree86-xfs package, which
needs to be fixed before xorg-x11 can be enabled in the development
tree.

The following is found in the spec file:
    BuildPreReq:    XFree86-xfs


This was present because the %install section uses
"/usr/X11R6/bin/mkfontdir", however mkfontdir has not been in the
XFree86-xfs package for quite a long time now, so this dependancy
is bogus.

mkfontdir should be getting called at font installation time, instead
of during package build time however, so this dependancy should
just be removed, and the call to mkfontdir should be removed as well.

The %pre/post scripts need to be modified to call mkfontdir like
the XFree86 and xorg-x11 font installation scripts do, so that
there is consistency with font installation across the distribution.
Also, when mkfontdir is used, it needs to have the umask set to
133 first, ie:

umask 133 ; /path/to/mkfontdir .

Otherwise it relies on root's umask, which could be changed.  This
can result in fonts.dir files that get created with the wrong
permissions and can prevent the xfs font server or X server from
starting up properly.
Comment 1 Mike A. Harris 2004-03-16 17:23:40 EST
Another problem I found:

Requires:       XFree86-75dpi-fonts
Comment 2 Mike A. Harris 2004-03-16 17:28:15 EST
Just noticed this ...

* Thu Jan 23 2003 Akira TAGOH <tagoh@redhat.com> 8.0-7
- remove the requirement of XFree86-100dpi-fonts.


The 75dpi one must have just gotten overlooked.
Comment 3 Akira TAGOH 2004-03-16 23:29:34 EST
Fixed in 8.0-12. Thanks!!
Comment 4 Mike A. Harris 2004-03-17 00:40:17 EST
Ok cool, thanks for the quick update!

Note You need to log in before you can comment on or make changes to this bug.