Bug 1184365 - Xnest/Xephyr Unsupported printf directive '*' in log.c:467
Summary: Xnest/Xephyr Unsupported printf directive '*' in log.c:467
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1184364
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-21 08:27 UTC by Tomas Pelka
Modified: 2015-07-22 05:51 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-server-1.15.0-34.el6
Doc Type: Bug Fix
Doc Text:
The string format used in error messages was not supported by the X server. When connecting to an unwilling XDMCP server, an error, a backtrace, and termination of the X server occurred instead of displaying an error message. Now, the X server supports the string format, connecting to an unwilling XDMCP server no longer causes a crash, and an error message is displayed prior to exiting cleanly.
Clone Of: 1184364
Environment:
Last Closed: 2015-07-22 05:51:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1445 normal SHIPPED_LIVE xorg-x11-server bug fix and enhancement update 2015-07-20 18:44:00 UTC

Description Tomas Pelka 2015-01-21 08:27:20 UTC
+++ This bug was initially created as a clone of Bug #1184364 +++

Description of problem:
When trying to connect to XDMCP via Xnest or Xephyr they both crash immediately, see the log below. 

Version-Release number of selected component (if applicable):
xorg-x11-server-Xephyr-1.15.0-31.el7
xorg-x11-server-Xnest-1.15.0-31.el7

How reproducible:
100%

Steps to Reproduce:
1. kdm --nodeamon with enabled Xdmcp running, 177 udp port opened, firewall down
2. [Xephyr|Xnest] :99 -query i386-6c-m1.ss.eng.bos.redhat.com
3.

Actual results:
    Xephyr -query i386-6c-m1.ss.eng.bos.redhat.com :99
    Initializing built-in extension Generic Event Extension
    Initializing built-in extension SHAPE
    Initializing built-in extension MIT-SHM
    Initializing built-in extension XInputExtension
    Initializing built-in extension XTEST
    Initializing built-in extension BIG-REQUESTS
    Initializing built-in extension SYNC
    Initializing built-in extension XKEYBOARD
    Initializing built-in extension XC-MISC
    Initializing built-in extension XINERAMA
    Initializing built-in extension XFIXES
    Initializing built-in extension RENDER
    Initializing built-in extension RANDR
    Initializing built-in extension COMPOSITE
    Initializing built-in extension DAMAGE
    Initializing built-in extension MIT-SCREEN-SAVER
    Initializing built-in extension DOUBLE-BUFFER
    Initializing built-in extension RECORD
    Initializing built-in extension DPMS
    Initializing built-in extension Present
    Initializing built-in extension X-Resource
    Initializing built-in extension XVideo
    Initializing built-in extension XVideo-MotionCompensation
    Initializing built-in extension SELinux
    Initializing built-in extension GLX
    (EE)
    Fatal server error:
    (EE) (EE) BUG: triggered 'if (f[f_idx])'
    (EE) BUG: log.c:467 in pnprintf()
    (EE) Unsupported printf directive '*'
    (EE)
    (EE) Backtrace:
    (EE) 0: Xephyr (xorg_backtrace+0x55) [0x583f95]
    (EE) 1: Xephyr (LogVMessageVerbSigSafe+0x875) [0x58f1d5]
    (EE) 2: Xephyr (FatalError+0xea) [0x58f4ca]
    (EE) 3: Xephyr (0x400000+0x19163b) [0x59163b]
    (EE) 4: Xephyr (0x400000+0x191c4d) [0x591c4d]
    (EE) 5: Xephyr (WakeupHandler+0x6d) [0x44c4bd]
    (EE) 6: Xephyr (WaitForSomething+0x1cf) [0x58193f]
    (EE) 7: Xephyr (0x400000+0x47751) [0x447751]
    (EE) 8: Xephyr (0x400000+0x4b95a) [0x44b95a]
    (EE) 9: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f5e05519af5]
    (EE) 10: Xephyr (0x400000+0x268e1) [0x4268e1]
    (EE)
    XDMCP fatal error: Manager unwilling %*.*s
    (EE)


Expected results:
should not crash on client site

Additional info:
rhel7, rhel6 and Fedora affected too

Comment 3 Adam Jackson 2015-05-04 18:10:03 UTC
Backported the * directive support from master.

Comment 7 errata-xmlrpc 2015-07-22 05:51:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1445.html


Note You need to log in before you can comment on or make changes to this bug.