Bug 11844 - kernel problems disregarded
kernel problems disregarded
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-02 01:33 EDT by tannhaus
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-27 17:13:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tannhaus 2000-06-02 01:33:31 EDT
PLEASE overlook reports 10976 and 10679 again.  People had problems with
these things and are STILL having problems and posting.  I'm running Redhat
6.1 until it is resolved and would really like to upgrade.  I'm sure there
are others out there in the same boat.  These are legitimate problems and I
feel they were dismissed too easily.  Please take time to overlook this
problem and resolve it without just saying it doesn't exist.  Thank you.
Comment 1 Rob McMillin 2000-08-27 11:27:39 EDT
I agree.  I am also having these problems.
Comment 2 Rob McMillin 2000-08-27 16:35:47 EDT
For fun: bug 10976 and bug 10679 (ease of reference).
Comment 3 Rob McMillin 2000-08-27 17:00:52 EDT
Hm.  I think I may have stumbled across the problem here, and a solution as
well. Here's a link from deja.com:

http://x73.deja.com/getdoc.xp?AN=651229629&CONTEXT=967409610.429588492&hitnum=17

If you set CONFIG_MODVERSIONS=y on a fast machine, modversions.h never gets
updated because the dependencies are not calculated correctly.

It appears that this bug has existed for quite some time and has even propagated
to the 2.4 kernel release series.

The short-term patch is to set CONFIG_MODVERSIONS=n. Mikael Pettersson
<mikpe@csd.uu.se> said in the above link that he is working on a patch that will
always get the modification times right. I don't know if he realizes that this
problem afflicts the 2.2.16 kernel as well...

I can say that the above fixed my problem.
Comment 4 Rob McMillin 2000-08-27 17:13:16 EDT
Also: a patch for the 2.4.0-test5 kernel can be had at the link following. I
haven't tried it, but it may fix the 2.2.16 bugs as well:

http://x54.deja.com/getdoc.xp?AN=652553155&CONTEXT=967410698.561971222&hitnum=16
Comment 5 Doug Ledford 2000-10-26 16:32:35 EDT
Since there are patches available, we'll wait for them to migrate through the
mainstream kernel into our kernels as a resolution to this problem.

Note You need to log in before you can comment on or make changes to this bug.